aboutsummaryrefslogtreecommitdiff
path: root/hw/usb/meson.build
diff options
context:
space:
mode:
authorVikram Garhwal <fnu.vikram@xilinx.com>2020-12-04 00:52:35 +0530
committerPeter Maydell <peter.maydell@linaro.org>2020-12-15 12:04:30 +0000
commit8bbe61f3c10446603514aeee0aafebaaa00e8d07 (patch)
tree729e26ebbd6112241bd458a991e99f1fe9f86ca1 /hw/usb/meson.build
parent50e76a73de1f7fb40fd84df3d5a98067c10cc097 (diff)
usb: Add DWC3 model
This patch adds skeleton model of dwc3 usb controller attached to xhci-sysbus device. It defines global register space of DWC3 controller, global registers control the AXI/AHB interfaces properties, external FIFO support and event count support. All of which are unimplemented at present,we are only supporting core reset and read of ID register. Signed-off-by: Vikram Garhwal <fnu.vikram@xilinx.com> Signed-off-by: Sai Pavan Boddu <sai.pavan.boddu@xilinx.com> Reviewed-by: Edgar E. Iglesias <edgar.iglesias@xilinx.com> Message-id: 1607023357-5096-3-git-send-email-sai.pavan.boddu@xilinx.com Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Diffstat (limited to 'hw/usb/meson.build')
-rw-r--r--hw/usb/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/usb/meson.build b/hw/usb/meson.build
index ecfec0a8f4..433c27e833 100644
--- a/hw/usb/meson.build
+++ b/hw/usb/meson.build
@@ -26,6 +26,7 @@ softmmu_ss.add(when: 'CONFIG_USB_XHCI_SYSBUS', if_true: files('hcd-xhci-sysbus.c
softmmu_ss.add(when: 'CONFIG_USB_XHCI_NEC', if_true: files('hcd-xhci-nec.c'))
softmmu_ss.add(when: 'CONFIG_USB_MUSB', if_true: files('hcd-musb.c'))
softmmu_ss.add(when: 'CONFIG_USB_DWC2', if_true: files('hcd-dwc2.c'))
+softmmu_ss.add(when: 'CONFIG_USB_DWC3', if_true: files('hcd-dwc3.c'))
softmmu_ss.add(when: 'CONFIG_TUSB6010', if_true: files('tusb6010.c'))
softmmu_ss.add(when: 'CONFIG_IMX', if_true: files('chipidea.c'))