aboutsummaryrefslogtreecommitdiff
path: root/hw/ssi/meson.build
diff options
context:
space:
mode:
authorRayhan Faizel <rayhan.faizel@gmail.com>2024-01-30 03:48:07 +0530
committerPeter Maydell <peter.maydell@linaro.org>2024-02-02 13:51:59 +0000
commit28004fb741343b77b1044a0f01d27d8b36b59651 (patch)
tree3e81a01356ade772ae502952f2a365a0b065efc7 /hw/ssi/meson.build
parentd710b337514d996db15e854e57a6f38b2685fbc0 (diff)
hw/ssi: Implement BCM2835 SPI Controller
This patch adds the SPI controller for the BCM2835. Polling and interrupt modes of transfer are supported. DMA and LoSSI modes are currently unimplemented. Signed-off-by: Rayhan Faizel <rayhan.faizel@gmail.com> Message-id: 20240129221807.2983148-2-rayhan.faizel@gmail.com Reviewed-by: Peter Maydell <peter.maydell@linaro.org> Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Diffstat (limited to 'hw/ssi/meson.build')
-rw-r--r--hw/ssi/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/ssi/meson.build b/hw/ssi/meson.build
index 0aebcdd614..b999aeb027 100644
--- a/hw/ssi/meson.build
+++ b/hw/ssi/meson.build
@@ -11,3 +11,4 @@ system_ss.add(when: 'CONFIG_XLNX_VERSAL', if_true: files('xlnx-versal-ospi.c'))
system_ss.add(when: 'CONFIG_IMX', if_true: files('imx_spi.c'))
system_ss.add(when: 'CONFIG_OMAP', if_true: files('omap_spi.c'))
system_ss.add(when: 'CONFIG_IBEX', if_true: files('ibex_spi_host.c'))
+system_ss.add(when: 'CONFIG_BCM2835_SPI', if_true: files('bcm2835_spi.c'))