aboutsummaryrefslogtreecommitdiff
path: root/hw/sensor/meson.build
diff options
context:
space:
mode:
authorJoel Stanley <joel@jms.id.au>2021-09-20 08:50:59 +0200
committerCédric Le Goater <clg@kaod.org>2021-09-20 08:50:59 +0200
commit46560cb1058af80a4c0c26eff2b07a51b02ee053 (patch)
tree4411a409aafd105f490a306de350f77971b2eaee /hw/sensor/meson.build
parentc5811bb3b76f8115f8ce3ccee64662a44dd061d9 (diff)
hw/misc: Add Infineon DPS310 sensor model
This contains some hardcoded register values that were obtained from the hardware after reading the temperature. It does enough to test the Linux kernel driver. The FIFO mode, IRQs and operation modes other than the default as used by Linux are not modelled. Signed-off-by: Joel Stanley <joel@jms.id.au> Message-Id: <20210616073358.750472-2-joel@jms.id.au> [ clg: - Fixed sequential reading - Reworked regs_reset_state array - Moved model under hw/sensor/ ] Message-Id: <20210629142336.750058-4-clg@kaod.org> Signed-off-by: Cédric Le Goater <clg@kaod.org>
Diffstat (limited to 'hw/sensor/meson.build')
-rw-r--r--hw/sensor/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/sensor/meson.build b/hw/sensor/meson.build
index 034e3e0207..059c4ca935 100644
--- a/hw/sensor/meson.build
+++ b/hw/sensor/meson.build
@@ -1,5 +1,6 @@
softmmu_ss.add(when: 'CONFIG_TMP105', if_true: files('tmp105.c'))
softmmu_ss.add(when: 'CONFIG_TMP421', if_true: files('tmp421.c'))
+softmmu_ss.add(when: 'CONFIG_DPS310', if_true: files('dps310.c'))
softmmu_ss.add(when: 'CONFIG_EMC141X', if_true: files('emc141x.c'))
softmmu_ss.add(when: 'CONFIG_ADM1272', if_true: files('adm1272.c'))
softmmu_ss.add(when: 'CONFIG_MAX34451', if_true: files('max34451.c'))