aboutsummaryrefslogtreecommitdiff
path: root/hw/sensor/meson.build
diff options
context:
space:
mode:
authorTitus Rwantare <titusr@google.com>2021-07-08 10:25:55 -0700
committerCorey Minyard <cminyard@mvista.com>2021-07-08 14:42:00 -0500
commit7215456a4fe6d7416fbad829ad25ec994d3a1cd0 (patch)
tree507abfc07ab6e6fda32899088371e1d39d8d65a0 /hw/sensor/meson.build
parentc0167539bae6da6baa07fe660d6bed07ed16c3e5 (diff)
hw/misc: add MAX34451 device
The MAX34451 is a Maxim power-supply system manager that can monitor up to 16 voltage rails or currents. It also contains a temperature sensor and supports up to four external temperature sensors. This commit adds support for interfacing with it, and setting limits on the supported sensors. Reviewed-by: Joel Stanley <joel@jms.id.au> Reviewed-by: Hao Wu <wuhaotsh@google.com> Signed-off-by: Titus Rwantare <titusr@google.com> Message-Id: <20210708172556.1868139-5-titusr@google.com> [Moved the device to the sensor directory] Signed-off-by: Corey Minyard <cminyard@mvista.com>
Diffstat (limited to 'hw/sensor/meson.build')
-rw-r--r--hw/sensor/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/sensor/meson.build b/hw/sensor/meson.build
index 8b319b5826..034e3e0207 100644
--- a/hw/sensor/meson.build
+++ b/hw/sensor/meson.build
@@ -2,3 +2,4 @@ softmmu_ss.add(when: 'CONFIG_TMP105', if_true: files('tmp105.c'))
softmmu_ss.add(when: 'CONFIG_TMP421', if_true: files('tmp421.c'))
softmmu_ss.add(when: 'CONFIG_EMC141X', if_true: files('emc141x.c'))
softmmu_ss.add(when: 'CONFIG_ADM1272', if_true: files('adm1272.c'))
+softmmu_ss.add(when: 'CONFIG_MAX34451', if_true: files('max34451.c'))