aboutsummaryrefslogtreecommitdiff
path: root/hw/sensor/meson.build
diff options
context:
space:
mode:
authorKevin Townsend <kevin.townsend@linaro.org>2022-01-30 10:50:32 +0100
committerPeter Maydell <peter.maydell@linaro.org>2022-02-08 10:56:29 +0000
commit4fd1ebb10593087d45d2f56f7f3d13447d24802c (patch)
tree596bff2b0a8588e6ac02004e0f067a1f9b5dc2b5 /hw/sensor/meson.build
parentd7d359c4ac1cafd1051c5f6f7ff8349aba579718 (diff)
hw/sensor: Add lsm303dlhc magnetometer device
This commit adds emulation of the magnetometer on the LSM303DLHC. It allows the magnetometer's X, Y and Z outputs to be set via the mag-x, mag-y and mag-z properties, as well as the 12-bit temperature output via the temperature property. Sensor can be enabled with 'CONFIG_LSM303DLHC_MAG=y'. Signed-off-by: Kevin Townsend <kevin.townsend@linaro.org> Message-id: 20220130095032.35392-1-kevin.townsend@linaro.org Reviewed-by: Peter Maydell <peter.maydell@linaro.org> Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Diffstat (limited to 'hw/sensor/meson.build')
-rw-r--r--hw/sensor/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/sensor/meson.build b/hw/sensor/meson.build
index 059c4ca935..d1bba290da 100644
--- a/hw/sensor/meson.build
+++ b/hw/sensor/meson.build
@@ -4,3 +4,4 @@ softmmu_ss.add(when: 'CONFIG_DPS310', if_true: files('dps310.c'))
softmmu_ss.add(when: 'CONFIG_EMC141X', if_true: files('emc141x.c'))
softmmu_ss.add(when: 'CONFIG_ADM1272', if_true: files('adm1272.c'))
softmmu_ss.add(when: 'CONFIG_MAX34451', if_true: files('max34451.c'))
+softmmu_ss.add(when: 'CONFIG_LSM303DLHC_MAG', if_true: files('lsm303dlhc_mag.c'))