aboutsummaryrefslogtreecommitdiff
path: root/hw/net/meson.build
diff options
context:
space:
mode:
authorDoug Evans <dje@google.com>2021-02-18 13:24:51 -0800
committerPeter Maydell <peter.maydell@linaro.org>2021-03-05 15:17:34 +0000
commit01c966b54f5effd7132da1a8d33ae1927944cfdf (patch)
tree7175fb1f0f258520333813b813b47ecc388c4ba7 /hw/net/meson.build
parented84a60ca80c403749c1fc1bab27c85d8edba39d (diff)
hw/net: Add npcm7xx emc model
This is a 10/100 ethernet device that has several features. Only the ones needed by the Linux driver have been implemented. See npcm7xx_emc.c for a list of unimplemented features. Reviewed-by: Hao Wu <wuhaotsh@google.com> Reviewed-by: Avi Fishman <avi.fishman@nuvoton.com> Signed-off-by: Doug Evans <dje@google.com> Message-id: 20210218212453.831406-2-dje@google.com Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Diffstat (limited to 'hw/net/meson.build')
-rw-r--r--hw/net/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/net/meson.build b/hw/net/meson.build
index 4a7051b54a..af0749c42b 100644
--- a/hw/net/meson.build
+++ b/hw/net/meson.build
@@ -35,6 +35,7 @@ softmmu_ss.add(when: 'CONFIG_I82596_COMMON', if_true: files('i82596.c'))
softmmu_ss.add(when: 'CONFIG_SUNHME', if_true: files('sunhme.c'))
softmmu_ss.add(when: 'CONFIG_FTGMAC100', if_true: files('ftgmac100.c'))
softmmu_ss.add(when: 'CONFIG_SUNGEM', if_true: files('sungem.c'))
+softmmu_ss.add(when: 'CONFIG_NPCM7XX', if_true: files('npcm7xx_emc.c'))
softmmu_ss.add(when: 'CONFIG_ETRAXFS', if_true: files('etraxfs_eth.c'))
softmmu_ss.add(when: 'CONFIG_COLDFIRE', if_true: files('mcf_fec.c'))