aboutsummaryrefslogtreecommitdiff
path: root/hw/misc/meson.build
diff options
context:
space:
mode:
authorLaurent Vivier <laurent@vivier.eu>2021-03-12 22:41:44 +0100
committerLaurent Vivier <laurent@vivier.eu>2021-03-15 21:02:57 +0100
commit0791bc02b8fbf9d55626b57f45255ba1b6ea83d5 (patch)
treeac7d6fdf6f66a3843ffbb057c7facc08554cbe3a /hw/misc/meson.build
parent2fde99ee3120416251922282c364833473135765 (diff)
m68k: add a system controller
Add a system controller for the m68k-virt machine. This controller allows the kernel to power off or reset the machine. Signed-off-by: Laurent Vivier <laurent@vivier.eu> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Tested-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Message-Id: <20210312214145.2936082-5-laurent@vivier.eu>
Diffstat (limited to 'hw/misc/meson.build')
-rw-r--r--hw/misc/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/hw/misc/meson.build b/hw/misc/meson.build
index 7a2b0d031a..21034dc60a 100644
--- a/hw/misc/meson.build
+++ b/hw/misc/meson.build
@@ -24,6 +24,9 @@ softmmu_ss.add(when: 'CONFIG_ARM11SCU', if_true: files('arm11scu.c'))
# Mac devices
softmmu_ss.add(when: 'CONFIG_MOS6522', if_true: files('mos6522.c'))
+# virt devices
+softmmu_ss.add(when: 'CONFIG_VIRT_CTRL', if_true: files('virt_ctrl.c'))
+
# RISC-V devices
softmmu_ss.add(when: 'CONFIG_MCHP_PFSOC_DMC', if_true: files('mchp_pfsoc_dmc.c'))
softmmu_ss.add(when: 'CONFIG_MCHP_PFSOC_IOSCB', if_true: files('mchp_pfsoc_ioscb.c'))