aboutsummaryrefslogtreecommitdiff
path: root/hw/intc/meson.build
diff options
context:
space:
mode:
authorThomas Huth <thuth@redhat.com>2023-01-10 10:53:48 +0100
committerPhilippe Mathieu-Daudé <philmd@linaro.org>2023-01-13 16:22:57 +0100
commit2b85e0cda4b066010efda63a2d2359872ba07a04 (patch)
tree9ce84374c3df2fb86a17e8a2d8362c03a9d7c047 /hw/intc/meson.build
parent2aaf0ec7ff239523ce2c8d913b120202c219af3e (diff)
hw/intc: Extract the IRQ counting functions into a separate file
These IRQ counting functions will soon be required in binaries that do not include the APIC code, too, so let's extract them into a separate file that can be linked independently of the APIC code. While we're at it, change the apic_* prefix into kvm_* since the functions are used from the i8259 PIC (i.e. not the APIC), too. Reviewed-by: Bernhard Beschow <shentey@gmail.com> Signed-off-by: Thomas Huth <thuth@redhat.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org> Reviewed-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk> Message-Id: <20230110095351.611724-2-thuth@redhat.com> Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Diffstat (limited to 'hw/intc/meson.build')
-rw-r--r--hw/intc/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/hw/intc/meson.build b/hw/intc/meson.build
index bcbf22ff51..cd9f1ee888 100644
--- a/hw/intc/meson.build
+++ b/hw/intc/meson.build
@@ -25,6 +25,12 @@ softmmu_ss.add(when: 'CONFIG_XILINX', if_true: files('xilinx_intc.c'))
softmmu_ss.add(when: 'CONFIG_XLNX_ZYNQMP', if_true: files('xlnx-zynqmp-ipi.c'))
softmmu_ss.add(when: 'CONFIG_XLNX_ZYNQMP_PMU', if_true: files('xlnx-pmu-iomod-intc.c'))
+if config_all_devices.has_key('CONFIG_APIC') or \
+ config_all_devices.has_key('CONFIG_I8259') or \
+ config_all_devices.has_key('CONFIG_MC146818RTC')
+ softmmu_ss.add(files('kvm_irqcount.c'))
+endif
+
specific_ss.add(when: 'CONFIG_ALLWINNER_A10_PIC', if_true: files('allwinner-a10-pic.c'))
specific_ss.add(when: 'CONFIG_APIC', if_true: files('apic.c', 'apic_common.c'))
specific_ss.add(when: 'CONFIG_ARM_GIC', if_true: files('arm_gicv3_cpuif_common.c'))