aboutsummaryrefslogtreecommitdiff
path: root/hw/intc/meson.build
diff options
context:
space:
mode:
authorLaurent Vivier <laurent@vivier.eu>2021-03-12 22:41:43 +0100
committerLaurent Vivier <laurent@vivier.eu>2021-03-15 21:02:20 +0100
commit2fde99ee3120416251922282c364833473135765 (patch)
tree78a7cdca9e7442bdc12cb978335b9eb5f94071d7 /hw/intc/meson.build
parent87855593903fdc1809d6f6c2ac7f344c31cea799 (diff)
m68k: add an interrupt controller
A (generic) copy of the GLUE device we already have for q800 to use with the m68k-virt machine. The q800 one would disappear in the future as q800 uses actually the djMEMC controller. Signed-off-by: Laurent Vivier <laurent@vivier.eu> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Tested-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Message-Id: <20210312214145.2936082-4-laurent@vivier.eu>
Diffstat (limited to 'hw/intc/meson.build')
-rw-r--r--hw/intc/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/intc/meson.build b/hw/intc/meson.build
index 5fcb923dd1..1c299039f6 100644
--- a/hw/intc/meson.build
+++ b/hw/intc/meson.build
@@ -58,3 +58,4 @@ specific_ss.add(when: 'CONFIG_XIVE', if_true: files('xive.c'))
specific_ss.add(when: ['CONFIG_KVM', 'CONFIG_XIVE'],
if_true: files('spapr_xive_kvm.c'))
specific_ss.add(when: 'CONFIG_GOLDFISH_PIC', if_true: files('goldfish_pic.c'))
+specific_ss.add(when: 'CONFIG_M68K_IRQC', if_true: files('m68k_irqc.c'))