aboutsummaryrefslogtreecommitdiff
path: root/hw/i386/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <philmd@redhat.com>2021-05-21 15:34:07 +0200
committerPhilippe Mathieu-Daudé <philmd@redhat.com>2021-07-14 22:28:58 +0200
commitb5b318608e20464c7136eb5a5f5f3307e9f90510 (patch)
treea5a5912a1704d2d821cf67bce031b88aa015b597 /hw/i386/meson.build
parent2165542c8d21c01d1f470560ab7d86b3fee8eac4 (diff)
hw/i386: Introduce X86_FW_OVMF Kconfig symbol
Introduce the X86_FW_OVMF Kconfig symbol for OVMF-specific code. Move the OVMF-specific code from pc_sysfw.c to pc_sysfw_ovmf.c, adding a pair of stubs. Update MAINTAINERS to reach OVMF maintainers when these new files are modified. This fixes when building the microvm machine standalone: /usr/bin/ld: libqemu-i386-softmmu.fa.p/target_i386_monitor.c.o: in function `qmp_sev_inject_launch_secret': target/i386/monitor.c:749: undefined reference to `pc_system_ovmf_table_find' Fixes: f522cef9b35 ("sev: update sev-inject-launch-secret to make gpa optional") Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com> Acked-by: Michael S. Tsirkin <mst@redhat.com> Message-Id: <20210616204328.2611406-22-philmd@redhat.com>
Diffstat (limited to 'hw/i386/meson.build')
-rw-r--r--hw/i386/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/hw/i386/meson.build b/hw/i386/meson.build
index e5d109f5c6..80dad29f2b 100644
--- a/hw/i386/meson.build
+++ b/hw/i386/meson.build
@@ -24,6 +24,8 @@ i386_ss.add(when: 'CONFIG_PC', if_true: files(
'pc_sysfw.c',
'acpi-build.c',
'port92.c'))
+i386_ss.add(when: 'CONFIG_X86_FW_OVMF', if_true: files('pc_sysfw_ovmf.c'),
+ if_false: files('pc_sysfw_ovmf-stubs.c'))
subdir('kvm')
subdir('xen')