aboutsummaryrefslogtreecommitdiff
path: root/hw/i386/kvm/meson.build
diff options
context:
space:
mode:
authorJoao Martins <joao.m.martins@oracle.com>2018-08-21 12:16:19 -0400
committerDavid Woodhouse <dwmw@amazon.co.uk>2023-03-01 08:22:50 +0000
commit507cb64d6e66d672bfddb275fe746241e0ed8db2 (patch)
tree4a45cf6af82dcfed99dfc60f2fa2af7b8e189d08 /hw/i386/kvm/meson.build
parenta15b10978fe62411936e577288f28184a41754a9 (diff)
i386/xen: add monitor commands to test event injection
Specifically add listing, injection of event channels. Signed-off-by: Joao Martins <joao.m.martins@oracle.com> Signed-off-by: David Woodhouse <dwmw@amazon.co.uk> Acked-by: Dr. David Alan Gilbert <dgilbert@redhat.com> Reviewed-by: Paul Durrant <paul@xen.org>
Diffstat (limited to 'hw/i386/kvm/meson.build')
-rw-r--r--hw/i386/kvm/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/hw/i386/kvm/meson.build b/hw/i386/kvm/meson.build
index cab64df339..325c901496 100644
--- a/hw/i386/kvm/meson.build
+++ b/hw/i386/kvm/meson.build
@@ -10,3 +10,10 @@ i386_kvm_ss.add(when: 'CONFIG_XEN_EMU', if_true: files(
))
i386_ss.add_all(when: 'CONFIG_KVM', if_true: i386_kvm_ss)
+
+xen_stubs_ss = ss.source_set()
+xen_stubs_ss.add(when: 'CONFIG_XEN_EMU', if_false: files(
+ 'xen-stubs.c',
+))
+
+specific_ss.add_all(when: 'CONFIG_SOFTMMU', if_true: xen_stubs_ss)