aboutsummaryrefslogtreecommitdiff
path: root/hw/i2c/meson.build
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2021-04-12 12:45:22 -0700
committerCorey Minyard <cminyard@mvista.com>2021-04-15 07:10:39 -0500
commit065177eeceff552a5316bff9435188b50a2da1b6 (patch)
tree9d3485ca8a4c1d5a71c10196226608bd85a7fae6 /hw/i2c/meson.build
parent3f9b32595e785c79720ed174198472c3d4d32c03 (diff)
hw/i2c: add pca954x i2c-mux switch
The pca954x is an i2c mux, and this adds support for two variants of this device: the pca9546 and pca9548. This device is very common on BMCs to route a different channel to each PCIe i2c bus downstream from the BMC. Signed-off-by: Patrick Venture <venture@google.com> Reviewed-by: Hao Wu <wuhaotsh@google.com> Reviewed-by: Havard Skinnemoen <hskinnemoen@google.com> Message-Id: <20210412194522.664594-5-venture@google.com> Signed-off-by: Corey Minyard <cminyard@mvista.com>
Diffstat (limited to 'hw/i2c/meson.build')
-rw-r--r--hw/i2c/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/i2c/meson.build b/hw/i2c/meson.build
index cdcd694a7f..dd3aef02b2 100644
--- a/hw/i2c/meson.build
+++ b/hw/i2c/meson.build
@@ -14,4 +14,5 @@ i2c_ss.add(when: 'CONFIG_SMBUS_EEPROM', if_true: files('smbus_eeprom.c'))
i2c_ss.add(when: 'CONFIG_VERSATILE_I2C', if_true: files('versatile_i2c.c'))
i2c_ss.add(when: 'CONFIG_OMAP', if_true: files('omap_i2c.c'))
i2c_ss.add(when: 'CONFIG_PPC4XX', if_true: files('ppc4xx_i2c.c'))
+i2c_ss.add(when: 'CONFIG_PCA954X', if_true: files('i2c_mux_pca954x.c'))
softmmu_ss.add_all(when: 'CONFIG_I2C', if_true: i2c_ss)