aboutsummaryrefslogtreecommitdiff
path: root/hw/core/meson.build
diff options
context:
space:
mode:
authorThomas Huth <thuth@redhat.com>2023-04-24 18:04:34 +0200
committerThomas Huth <thuth@redhat.com>2023-05-16 09:14:18 +0200
commit89c81b3d4c1ccafa22f58a6169c9410003654b8e (patch)
tree3fbbef7a25b01398b56d384baac0a5b84d9bb63e /hw/core/meson.build
parent1077f50b23065a1d07cbbc6bad1141d50a5d25b9 (diff)
hw/core: Move machine-qmp-cmds.c into the target independent source set
The only target specific code that is left in here are two spots that use TARGET_NAME. Change them to use the new target_name() wrapper function instead, so we can move the file into the common softmmu_ss source set. That way we only have to compile this file once, and not for each target anymore. Message-Id: <20230424160434.331175-4-thuth@redhat.com> Signed-off-by: Thomas Huth <thuth@redhat.com>
Diffstat (limited to 'hw/core/meson.build')
-rw-r--r--hw/core/meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/hw/core/meson.build b/hw/core/meson.build
index ae977c9396..959bc924d4 100644
--- a/hw/core/meson.build
+++ b/hw/core/meson.build
@@ -41,6 +41,7 @@ softmmu_ss.add(files(
'gpio.c',
'loader.c',
'machine-hmp-cmds.c',
+ 'machine-qmp-cmds.c',
'machine.c',
'nmi.c',
'null-machine.c',
@@ -51,7 +52,3 @@ softmmu_ss.add(files(
'vm-change-state-handler.c',
'clock-vmstate.c',
))
-
-specific_ss.add(when: 'CONFIG_SOFTMMU', if_true: files(
- 'machine-qmp-cmds.c',
-))