aboutsummaryrefslogtreecommitdiff
path: root/hw/core/meson.build
diff options
context:
space:
mode:
authorAlex Bennée <alex.bennee@linaro.org>2021-03-03 17:36:39 +0000
committerAlex Bennée <alex.bennee@linaro.org>2021-03-10 15:34:11 +0000
commita33ff6d2c6bd480fbab3bc9f748655a9269881eb (patch)
tree6d9648a35dd1eeaaa7820918ef4e0d7dccdbff0f /hw/core/meson.build
parent78da6a1bca224a8c1c4b1bdf2ca8ec19c74c6fc1 (diff)
hw/core: implement a guest-loader to support static hypervisor guests
Hypervisors, especially type-1 ones, need the firmware/bootcode to put their initial guest somewhere in memory and pass the information to it via platform data. The guest-loader is modelled after the generic loader for exactly this sort of purpose: $QEMU $ARGS -kernel ~/xen.git/xen/xen \ -append "dom0_mem=1G,max:1G loglvl=all guest_loglvl=all" \ -device guest-loader,addr=0x42000000,kernel=Image,bootargs="root=/dev/sda2 ro console=hvc0 earlyprintk=xen" \ -device guest-loader,addr=0x47000000,initrd=rootfs.cpio Signed-off-by: Alex Bennée <alex.bennee@linaro.org> Reviewed-by: Alistair Francis <alistair.francis@wdc.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20210303173642.3805-5-alex.bennee@linaro.org>
Diffstat (limited to 'hw/core/meson.build')
-rw-r--r--hw/core/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/hw/core/meson.build b/hw/core/meson.build
index 032576f571..9cd72edf51 100644
--- a/hw/core/meson.build
+++ b/hw/core/meson.build
@@ -37,6 +37,8 @@ softmmu_ss.add(files(
'clock-vmstate.c',
))
+softmmu_ss.add(when: 'CONFIG_TCG', if_true: files('guest-loader.c'))
+
specific_ss.add(when: 'CONFIG_SOFTMMU', if_true: files(
'machine-qmp-cmds.c',
'numa.c',