aboutsummaryrefslogtreecommitdiff
path: root/gdbstub/meson.build
diff options
context:
space:
mode:
authorRichard Henderson <richard.henderson@linaro.org>2023-03-02 18:58:04 -0800
committerAlex Bennée <alex.bennee@linaro.org>2023-03-07 20:44:09 +0000
commit2d3d2517cc78763cc31da053a29786c53ccd90a2 (patch)
tree3eb79e8c39a6659507a7dfa7978b183ae94b5fcb /gdbstub/meson.build
parentad66b5cbbb9a4f92e2a4f0af5902524bbd60ee67 (diff)
gdbstub: Build syscall.c once
There is no longer anything target specific. Signed-off-by: Richard Henderson <richard.henderson@linaro.org> Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org> Signed-off-by: Alex Bennée <alex.bennee@linaro.org> Message-Id: <20230303025805.625589-29-richard.henderson@linaro.org>
Diffstat (limited to 'gdbstub/meson.build')
-rw-r--r--gdbstub/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/gdbstub/meson.build b/gdbstub/meson.build
index d679c7ab86..bd5c5cd67d 100644
--- a/gdbstub/meson.build
+++ b/gdbstub/meson.build
@@ -31,8 +31,7 @@ user_ss.add(gdb_user)
gdb_softmmu = declare_dependency(link_whole: libgdb_softmmu)
softmmu_ss.add(gdb_softmmu)
-# These have to built to the target ABI
-specific_ss.add(files('syscalls.c'))
+common_ss.add(files('syscalls.c'))
# The user-target is specialised by the guest
specific_ss.add(when: 'CONFIG_USER_ONLY', if_true: files('user-target.c'))