aboutsummaryrefslogtreecommitdiff
path: root/docs/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2020-11-03 08:59:42 -0500
committerPaolo Bonzini <pbonzini@redhat.com>2020-11-03 09:42:54 -0500
commitaf2c0e854bd2b93a61f2d7111822154ccccd86c9 (patch)
treece35196b1cf7c7eeddaf078bb184e25e1e26513d /docs/meson.build
parent0250edf1eb4ff0b164c0cdabcbf4313507f3082e (diff)
meson: fix warning for bad sphinx-build
The warning was printing an empty string if the bad sphinx-build was not passed on the command line. Instead, always use the path that was returned by find_program. Reported-by: Peter Maydell <peter.maydell@linaro.org> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'docs/meson.build')
-rw-r--r--docs/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/docs/meson.build b/docs/meson.build
index 8c222f96bb..bf8204a08f 100644
--- a/docs/meson.build
+++ b/docs/meson.build
@@ -27,7 +27,8 @@ if sphinx_build.found()
build_docs = (sphinx_build_test_out.returncode() == 0)
if not build_docs
- warning('@0@ exists but it is either too old or uses too old a Python version'.format(get_option('sphinx_build')))
+ warning('@0@ is either too old or uses too old a Python version'
+ .format(sphinx_build.full_path()))
if get_option('docs').enabled()
error('Install a Python 3 version of python-sphinx')
endif