aboutsummaryrefslogtreecommitdiff
path: root/disas/meson.build
diff options
context:
space:
mode:
authorChristoph Müllner <christoph.muellner@vrull.eu>2023-06-12 13:10:34 +0200
committerAlistair Francis <alistair.francis@wdc.com>2023-07-10 22:29:14 +1000
commit318df7238b9f842af96aad01ec183012c8fecab9 (patch)
tree7a1a7c1e60875c973c7010443f6103b8c800e220 /disas/meson.build
parentf6f72338d80ec6f15a6b18643797bc10901aadf3 (diff)
disas/riscv: Add support for XThead* instructions
Support for emulating XThead* instruction has been added recently. This patch adds support for these instructions to the RISC-V disassembler. Co-developed-by: LIU Zhiwei <zhiwei_liu@linux.alibaba.com> Acked-by: Alistair Francis <alistair.francis@wdc.com> Signed-off-by: Christoph Müllner <christoph.muellner@vrull.eu> Message-Id: <20230612111034.3955227-9-christoph.muellner@vrull.eu> Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
Diffstat (limited to 'disas/meson.build')
-rw-r--r--disas/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/disas/meson.build b/disas/meson.build
index f2b21e120f..815523ab85 100644
--- a/disas/meson.build
+++ b/disas/meson.build
@@ -8,6 +8,7 @@ common_ss.add(when: 'CONFIG_MIPS_DIS', if_true: files('mips.c', 'nanomips.c'))
common_ss.add(when: 'CONFIG_NIOS2_DIS', if_true: files('nios2.c'))
common_ss.add(when: 'CONFIG_RISCV_DIS', if_true: files(
'riscv.c',
+ 'riscv-xthead.c',
'riscv-xventana.c'
))
common_ss.add(when: 'CONFIG_SH4_DIS', if_true: files('sh4.c'))