aboutsummaryrefslogtreecommitdiff
path: root/disas/meson.build
diff options
context:
space:
mode:
authorThomas Huth <thuth@redhat.com>2023-05-09 17:27:48 +0100
committerRichard Henderson <richard.henderson@linaro.org>2023-05-11 09:51:07 +0100
commiteb0153efa6fa58b2c9d891b17766dbedc10e31b5 (patch)
treecd69d8a2e4097f5b6fbc92893add541c42bceb94 /disas/meson.build
parente22d3c48db6fea230a24881a6a29766f2156283a (diff)
disas: Move disas.c into the target-independent source set
Use target_words_bigendian() instead of an ifdef. Remove CONFIG_RISCV_DIS from the check for riscv as a host; this is a poisoned identifier, and anyway will always be set by meson.build when building on a riscv host. Signed-off-by: Thomas Huth <thuth@redhat.com> Message-Id: <20230508133745.109463-3-thuth@redhat.com> [rth: Type change done in a separate patch] Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'disas/meson.build')
-rw-r--r--disas/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/disas/meson.build b/disas/meson.build
index f40230c58f..832727e4b3 100644
--- a/disas/meson.build
+++ b/disas/meson.build
@@ -11,6 +11,7 @@ common_ss.add(when: 'CONFIG_SH4_DIS', if_true: files('sh4.c'))
common_ss.add(when: 'CONFIG_SPARC_DIS', if_true: files('sparc.c'))
common_ss.add(when: 'CONFIG_XTENSA_DIS', if_true: files('xtensa.c'))
common_ss.add(when: capstone, if_true: [files('capstone.c'), capstone])
+common_ss.add(files('disas.c'))
softmmu_ss.add(files('disas-mon.c'))
-specific_ss.add(files('disas.c'), capstone)
+specific_ss.add(capstone)