aboutsummaryrefslogtreecommitdiff
path: root/crypto/meson.build
diff options
context:
space:
mode:
authorzhenwei pi <pizhenwei@bytedance.com>2022-05-25 17:01:12 +0800
committerDaniel P. Berrangé <berrange@redhat.com>2022-05-26 11:41:47 +0100
commitdb5ca5fbfa6597ac9dd1ae40f986696db9c8b9dd (patch)
tree4acb26c640711c2475dc4bdd25557a71f3bf525b /crypto/meson.build
parentdaa55f3ecf2d413295eb2d539e7629fc05d7bc92 (diff)
crypto: Introduce akcipher crypto class
Introduce new akcipher crypto class 'QCryptoAkCIpher', which supports basic asymmetric operations: encrypt, decrypt, sign and verify. Suggested by Daniel P. Berrangé, also add autoptr cleanup for the new class. Thanks to Daniel! Co-developed-by: lei he <helei.sig11@bytedance.com> Signed-off-by: lei he <helei.sig11@bytedance.com> Signed-off-by: zhenwei pi <pizhenwei@bytedance.com> Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'crypto/meson.build')
-rw-r--r--crypto/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/crypto/meson.build b/crypto/meson.build
index 685fb37097..313f935f27 100644
--- a/crypto/meson.build
+++ b/crypto/meson.build
@@ -1,6 +1,7 @@
crypto_ss.add(genh)
crypto_ss.add(files(
'afsplit.c',
+ 'akcipher.c',
'block-luks.c',
'block-qcow.c',
'block.c',