aboutsummaryrefslogtreecommitdiff
path: root/crypto/meson.build
diff options
context:
space:
mode:
authorDaniel P. Berrangé <berrange@redhat.com>2021-06-25 18:32:14 +0100
committerDaniel P. Berrangé <berrange@redhat.com>2021-07-14 14:15:52 +0100
commit8c1d3dc772352284e7f8757131f2ed3f483dd922 (patch)
tree847dc84f47059a4c29e7663a4da0f4b625c0a403 /crypto/meson.build
parent678307b605da9ebbda3a6269b5a6ab2d3002e241 (diff)
crypto: add gnutls pbkdf provider
This adds support for using gnutls as a provider of the crypto pbkdf APIs. Reviewed-by: Eric Blake <eblake@redhat.com> Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'crypto/meson.build')
-rw-r--r--crypto/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/crypto/meson.build b/crypto/meson.build
index e2f25810fc..95a6a83504 100644
--- a/crypto/meson.build
+++ b/crypto/meson.build
@@ -29,7 +29,7 @@ if nettle.found()
elif gcrypt.found()
crypto_ss.add(gcrypt, files('hash-gcrypt.c', 'hmac-gcrypt.c', 'pbkdf-gcrypt.c'))
elif gnutls_crypto.found()
- crypto_ss.add(gnutls, files('hash-gnutls.c', 'hmac-glib.c', 'pbkdf-stub.c')
+ crypto_ss.add(gnutls, files('hash-gnutls.c', 'hmac-gnutls.c', 'pbkdf-gnutls.c'))
else
crypto_ss.add(files('hash-glib.c', 'hmac-glib.c', 'pbkdf-stub.c'))
endif