aboutsummaryrefslogtreecommitdiff
path: root/crypto/meson.build
diff options
context:
space:
mode:
authorRichard Henderson <richard.henderson@linaro.org>2023-07-10 15:38:28 +0100
committerRichard Henderson <richard.henderson@linaro.org>2023-09-15 13:56:59 +0000
commit07f348d77c35b6ff1f99075e20bffbf67e772d8b (patch)
treec494a756066e9c2a880d6e5c23897943d7e834da /crypto/meson.build
parent005ad32358f12fe9313a4a01918a55e60d4f39e5 (diff)
crypto: Add generic 8-bit carry-less multiply routines
Reviewed-by: Ard Biesheuvel <ardb@kernel.org> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'crypto/meson.build')
-rw-r--r--crypto/meson.build9
1 files changed, 6 insertions, 3 deletions
diff --git a/crypto/meson.build b/crypto/meson.build
index 5f03a30d34..9ac1a89802 100644
--- a/crypto/meson.build
+++ b/crypto/meson.build
@@ -48,9 +48,12 @@ if have_afalg
endif
crypto_ss.add(when: gnutls, if_true: files('tls-cipher-suites.c'))
-util_ss.add(files('sm4.c'))
-util_ss.add(files('aes.c'))
-util_ss.add(files('init.c'))
+util_ss.add(files(
+ 'aes.c',
+ 'clmul.c',
+ 'init.c',
+ 'sm4.c',
+))
if gnutls.found()
util_ss.add(gnutls)
endif