aboutsummaryrefslogtreecommitdiff
path: root/crypto/meson.build
diff options
context:
space:
mode:
authorLei He <helei.sig11@bytedance.com>2022-05-25 17:01:14 +0800
committerDaniel P. Berrangé <berrange@redhat.com>2022-05-26 11:41:51 +0100
commit4c5e512ee0c49efb42286600aef31739c0dcee5d (patch)
treedc6255202c5819ab77cf22598c5430a8128b286d /crypto/meson.build
parent99d423f10c636c39405924e68584f50f78a0bb8c (diff)
crypto: Implement RSA algorithm by hogweed
Implement RSA algorithm by hogweed from nettle. Thus QEMU supports a 'real' RSA backend to handle request from guest side. It's important to test RSA offload case without OS & hardware requirement. Signed-off-by: lei he <helei.sig11@bytedance.com> Signed-off-by: zhenwei pi <pizhenwei@bytedance.com> Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'crypto/meson.build')
-rw-r--r--crypto/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/crypto/meson.build b/crypto/meson.build
index b8152ae7cb..5f03a30d34 100644
--- a/crypto/meson.build
+++ b/crypto/meson.build
@@ -21,10 +21,14 @@ crypto_ss.add(files(
'tlscredspsk.c',
'tlscredsx509.c',
'tlssession.c',
+ 'rsakey.c',
))
if nettle.found()
crypto_ss.add(nettle, files('hash-nettle.c', 'hmac-nettle.c', 'pbkdf-nettle.c'))
+ if hogweed.found()
+ crypto_ss.add(gmp, hogweed)
+ endif
if xts == 'private'
crypto_ss.add(files('xts.c'))
endif