aboutsummaryrefslogtreecommitdiff
path: root/chardev/meson.build
diff options
context:
space:
mode:
authorPeter Maydell <peter.maydell@linaro.org>2020-08-21 12:42:49 +0100
committerPeter Maydell <peter.maydell@linaro.org>2020-08-21 12:42:49 +0100
commit7fd51e68c34fcefdb4d6fd646ed3346f780f89f4 (patch)
treeb4c90dc51c2babb9850d29d0e3349891b2988172 /chardev/meson.build
parent1d806cef0e38b5db8347a8e12f214d543204a314 (diff)
parenta14f0bf1657adef0328a3a756637b93f53ec0220 (diff)
Merge remote-tracking branch 'remotes/bonzini-gitlab/tags/for-upstream' into staging
New build system, with "fake in-tree builds" support. Missing: * converting configure tests * converting unit tests * converting some remaining parts of the installation # gpg: Signature made Fri 21 Aug 2020 11:33:35 BST # gpg: using RSA key F13338574B662389866C7682BFFBD25F78C7AE83 # gpg: issuer "pbonzini@redhat.com" # gpg: Good signature from "Paolo Bonzini <bonzini@gnu.org>" [full] # gpg: aka "Paolo Bonzini <pbonzini@redhat.com>" [full] # Primary key fingerprint: 46F5 9FBD 57D6 12E7 BFD4 E2F7 7E15 100C CD36 69B1 # Subkey fingerprint: F133 3857 4B66 2389 866C 7682 BFFB D25F 78C7 AE83 * remotes/bonzini-gitlab/tags/for-upstream: (152 commits) docs: convert build system documentation to rST meson: update build-system documentation meson: avoid unstable module warning with Meson 0.56.0 or newer meson: convert po/ meson: convert VNC and dependent libraries to meson meson: move SDL and SDL-image detection to meson meson: convert sample plugins meson: replace create-config with meson configure_file rules.mak: drop unneeded macros meson: convert check-block meson: build texi doc docs: automatically track manual dependencies meson: sphinx-build remove Makefile.target rules.mak: remove version.o meson: convert systemtap files configure: place compatibility symlinks in target directories meson: link emulators without Makefile.target meson: plugins meson: cpu-emu ... Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Diffstat (limited to 'chardev/meson.build')
-rw-r--r--chardev/meson.build45
1 files changed, 45 insertions, 0 deletions
diff --git a/chardev/meson.build b/chardev/meson.build
new file mode 100644
index 0000000000..a46a6237be
--- /dev/null
+++ b/chardev/meson.build
@@ -0,0 +1,45 @@
+chardev_ss = ss.source_set()
+chardev_ss.add(files(
+ 'char-fe.c',
+ 'char-file.c',
+ 'char-io.c',
+ 'char-mux.c',
+ 'char-null.c',
+ 'char-pipe.c',
+ 'char-ringbuf.c',
+ 'char-serial.c',
+ 'char-socket.c',
+ 'char-stdio.c',
+ 'char-udp.c',
+ 'char.c',
+))
+chardev_ss.add(when: 'CONFIG_POSIX', if_true: files(
+ 'char-fd.c',
+ 'char-parallel.c',
+ 'char-pty.c',
+))
+chardev_ss.add(when: 'CONFIG_WIN32', if_true: files(
+ 'char-console.c',
+ 'char-win-stdio.c',
+ 'char-win.c',
+))
+
+chardev_ss = chardev_ss.apply(config_host, strict: false)
+libchardev = static_library('chardev', chardev_ss.sources() + genh,
+ name_suffix: 'fa',
+ build_by_default: false)
+
+chardev = declare_dependency(link_whole: libchardev)
+
+softmmu_ss.add(files('chardev-sysemu.c', 'msmouse.c', 'wctablet.c', 'testdev.c'))
+softmmu_ss.add(when: ['CONFIG_SPICE', spice], if_true: files('spice.c'))
+
+chardev_modules = {}
+
+if config_host.has_key('CONFIG_BRLAPI') and sdl.found()
+ module_ss = ss.source_set()
+ module_ss.add(when: [sdl, brlapi], if_true: files('baum.c'))
+ chardev_modules += { 'brlapi': module_ss }
+endif
+
+modules += { 'chardev': chardev_modules }