aboutsummaryrefslogtreecommitdiff
path: root/block/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2020-08-28 19:32:40 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2020-09-01 01:51:51 -0400
commita10c8516ed59c1e4c0db9b0d9050960ed861703d (patch)
tree62ed8f07248c2440b0d5efb398ddba14a1f349d8 /block/meson.build
parent46504430e6b1f96ca8d805117ee4e20b74544c9f (diff)
block: always link with zlib
The qcow2 driver needs the zlib dependency. While emulators provided it through the migration code, this is not true of the tools. Move the dependency from the qcow1 rule directly into block_ss so that it is included unconditionally. Fixes build with --disable-qcow1. Reported-by: Thomas Huth <thuth@redhat.com> Reviewed-by: Thomas Huth <thuth@redhat.com> Cc: qemu-block@nongnu.org Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'block/meson.build')
-rw-r--r--block/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/block/meson.build b/block/meson.build
index 4dbbfe60b4..a3e56b7cd1 100644
--- a/block/meson.build
+++ b/block/meson.build
@@ -40,9 +40,9 @@ block_ss.add(files(
'vmdk.c',
'vpc.c',
'write-threshold.c',
-), zstd)
+), zstd, zlib)
-block_ss.add(when: [zlib, 'CONFIG_QCOW1'], if_true: files('qcow.c'))
+block_ss.add(when: 'CONFIG_QCOW1', if_true: files('qcow.c'))
block_ss.add(when: 'CONFIG_VDI', if_true: files('vdi.c'))
block_ss.add(when: 'CONFIG_CLOOP', if_true: files('cloop.c'))
block_ss.add(when: 'CONFIG_BOCHS', if_true: files('bochs.c'))