aboutsummaryrefslogtreecommitdiff
path: root/backends/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2023-08-30 11:29:54 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2023-12-31 09:11:28 +0100
commitdc4954943d3adc82c4052aed592f2dc5a14c3fc7 (patch)
tree0d32d75c6625bf9c1171bc5319422e6c188d6bd4 /backends/meson.build
parent53e8868d69c195b6b57ccc6847057043c26df1b6 (diff)
meson: remove CONFIG_POSIX and CONFIG_WIN32 from config_targetos
For consistency with other OSes, use if...endif for rules that are target-independent. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'backends/meson.build')
-rw-r--r--backends/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/backends/meson.build b/backends/meson.build
index 248ce4923c..6dee4e9203 100644
--- a/backends/meson.build
+++ b/backends/meson.build
@@ -10,8 +10,10 @@ system_ss.add([files(
'confidential-guest-support.c',
), numa])
-system_ss.add(when: 'CONFIG_POSIX', if_true: files('rng-random.c'))
-system_ss.add(when: 'CONFIG_POSIX', if_true: files('hostmem-file.c'))
+if targetos != 'windows'
+ system_ss.add(files('rng-random.c'))
+ system_ss.add(files('hostmem-file.c'))
+endif
if targetos == 'linux'
system_ss.add(files('hostmem-memfd.c'))
endif