aboutsummaryrefslogtreecommitdiff
path: root/backends/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2023-11-03 09:17:48 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2023-12-31 09:11:29 +0100
commitd0cda6f461fd33c5f9b063781c63c1ce5fd3fa3b (patch)
treec48bd2a0ab0da96761a6b75cdb66cb1ed36a5090 /backends/meson.build
parentcfc1a889e509ffeba6e44cca8ff626751bc4219e (diff)
configure, meson: rename targetos to host_os
This variable is about the host OS, not the target. It is used a lot more since the Meson conversion, but the original sin dates back to 2003. Time to fix it. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'backends/meson.build')
-rw-r--r--backends/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/backends/meson.build b/backends/meson.build
index 6dee4e9203..8b2b111497 100644
--- a/backends/meson.build
+++ b/backends/meson.build
@@ -10,11 +10,11 @@ system_ss.add([files(
'confidential-guest-support.c',
), numa])
-if targetos != 'windows'
+if host_os != 'windows'
system_ss.add(files('rng-random.c'))
system_ss.add(files('hostmem-file.c'))
endif
-if targetos == 'linux'
+if host_os == 'linux'
system_ss.add(files('hostmem-memfd.c'))
endif
if keyutils.found()