aboutsummaryrefslogtreecommitdiff
path: root/backends/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2019-07-24 19:23:16 +0400
committerPaolo Bonzini <pbonzini@redhat.com>2020-08-21 06:30:23 -0400
commitab3180515c6a5f080623cde07c9b89ece77abb19 (patch)
tree4a5d2c16c307f1914adfa42fcaed3ecf6c108d0c /backends/meson.build
parentcdaf07228cf42d708fe24371a68cec022841e018 (diff)
meson: convert backends directory to Meson
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'backends/meson.build')
-rw-r--r--backends/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/backends/meson.build b/backends/meson.build
new file mode 100644
index 0000000000..484456ece7
--- /dev/null
+++ b/backends/meson.build
@@ -0,0 +1,19 @@
+softmmu_ss.add([files(
+ 'cryptodev-builtin.c',
+ 'cryptodev.c',
+ 'hostmem-ram.c',
+ 'hostmem.c',
+ 'rng-builtin.c',
+ 'rng-egd.c',
+ 'rng.c',
+), numa])
+
+softmmu_ss.add(when: 'CONFIG_POSIX', if_true: files('rng-random.c'))
+softmmu_ss.add(when: 'CONFIG_POSIX', if_true: files('hostmem-file.c'))
+softmmu_ss.add(when: 'CONFIG_LINUX', if_true: files('hostmem-memfd.c'))
+softmmu_ss.add(when: ['CONFIG_VHOST_USER', 'CONFIG_VIRTIO'], if_true: files('vhost-user.c'))
+softmmu_ss.add(when: 'CONFIG_VIRTIO_CRYPTO', if_true: files('cryptodev-vhost.c'))
+softmmu_ss.add(when: ['CONFIG_VIRTIO_CRYPTO', 'CONFIG_VHOST_CRYPTO'], if_true: files('cryptodev-vhost-user.c'))
+softmmu_ss.add(when: 'CONFIG_GIO', if_true: [files('dbus-vmstate.c'), gio])
+
+subdir('tpm')