Age | Commit message (Collapse) | Author | |
---|---|---|---|
2016-01-28 | Merge #7212: Adds unittests for CAddrMan and CAddrinfo, removes source of ↵ | Wladimir J. van der Laan | |
non-determinism. 40c87b6 Increase test coverage for addrman and addrinfo (Ethan Heilman) | |||
2016-01-28 | Merge #7348: MOVE ONLY: move rpc* to rpc/ | Wladimir J. van der Laan | |
d13f65e rpc: update inline comments to refer to new file paths (Daniel Cousens) a0eaff8 move rpc* to rpc/ (Daniel Cousens) | |||
2016-01-28 | Merge #7415: net: Hardcoded seeds update January 2016 | Wladimir J. van der Laan | |
4818dba net: Hardcoded seeds update January 2016 (Wladimir J. van der Laan) | |||
2016-01-28 | Merge #7396: [Qt] Add option to increase/decrease font size in the console ↵ | Jonas Schnelli | |
window 43abb02 [Qt] Add a new chevron/arrow icon for the console prompt line (Jonas Schnelli) 56c9e66 [Qt] keep scroll position in GUI console after changing font size (Jonas Schnelli) 3a3a927 [Qt] Add option to increase/decrease font size in the console window (Jonas Schnelli) | |||
2016-01-28 | Accept replacebyfee=opt-in for turning on opt-in RBF | Luke Dashjr | |
Basic forward-compatibility with more flexible parameters like fss | |||
2016-01-28 | Rename permitrbf to replacebyfee | Luke Dashjr | |
"permit" is currently used to configure transaction filtering, whereas replacement is more to do with the memory pool state than the transaction itself. | |||
2016-01-27 | splashscreen: Resize text to fit exactly | Luke Dashjr | |
2016-01-27 | Increase test coverage for addrman and addrinfo | Ethan Heilman | |
Adds several unittests for CAddrMan and CAddrInfo. Increases the accuracy of addrman tests. Removes non-determinism in tests by overriding the random number generator. Extracts testing code from addrman class to test class. | |||
2016-01-27 | Merge #7300: [trivial] Add missing copyright headers | Wladimir J. van der Laan | |
fabcee1 Remove copyright header from autogenerated chainparamsseeds.h (MarcoFalke) fa60d05 Add missing copyright headers (MarcoFalke) fa7e4c0 Bump copyright headers to 2014 (MarcoFalke) | |||
2016-01-26 | release: add check-symbols and check-security make targets | Cory Fields | |
These are not added to the default checks because some of them depend on release-build configs. | |||
2016-01-26 | [Qt] Add a new chevron/arrow icon for the console prompt line | Jonas Schnelli | |
2016-01-25 | Merge #7391: [init] Clarify help message | Wladimir J. van der Laan | |
fae78fa [init] Clarify permitrbf help message (MarcoFalke) | |||
2016-01-25 | net: Hardcoded seeds update January 2016 | Wladimir J. van der Laan | |
2016-01-23 | [init] Clarify permitrbf help message | MarcoFalke | |
2016-01-23 | Merge #7384: [qt] Peertable: Increase SUBVERSION_COLUMN_WIDTH | Jonas Schnelli | |
faa9011 [qt] Peertable: Increase SUBVERSION_COLUMN_WIDTH (MarcoFalke) | |||
2016-01-23 | [Qt] keep scroll position in GUI console after changing font size | Jonas Schnelli | |
2016-01-22 | [Qt] Add option to increase/decrease font size in the console window | Jonas Schnelli | |
2016-01-22 | Merge #7262: Reduce inefficiency of GetAccountAddress() | Wladimir J. van der Laan | |
2409865 Reduce inefficiency of GetAccountAddress() (Chris Moore) | |||
2016-01-22 | Merge #7056: Save last db read | Wladimir J. van der Laan | |
8504867 Save the last unnecessary database read (Alex Morcos) | |||
2016-01-22 | Merge #7364: [qt] Windows: Make rpcconsole monospace font larger | Jonas Schnelli | |
fa6a59d [qt] Windows: Make rpcconsole monospace font larger (MarcoFalke) | |||
2016-01-21 | Add option `-permitrbf` to set transaction replacement policy | Wladimir J. van der Laan | |
Add a configuration option `-permitrbf` to set transaction replacement policy for the mempool. Enabling it will enable (opt-in) RBF, disabling it will refuse all conflicting transactions. | |||
2016-01-21 | Merge #7383: [Qt] rename "amount" to "requested amount" in receive coins table | Jonas Schnelli | |
df6e8e1 [Qt] rename "amount" to "requested amount" in receive coins table (Jonas Schnelli) | |||
2016-01-20 | [qt] Peertable: Increase SUBVERSION_COLUMN_WIDTH | MarcoFalke | |
2016-01-21 | rpc: update inline comments to refer to new file paths | Daniel Cousens | |
2016-01-21 | move rpc* to rpc/ | Daniel Cousens | |
2016-01-20 | [Qt] rename "amount" to "requested amount" in receive coins table | Jonas Schnelli | |
2016-01-20 | Merge #7183: Improved readability of ApproximateBestSubset | Wladimir J. van der Laan | |
96efcad Improved readability of sorting for coin selection. (Murch) | |||
2016-01-20 | Merge #7307: [RPC, Wallet] Move RPC dispatch table registration to wallet/ code | Wladimir J. van der Laan | |
dd2dc40 [RPC, Wallet] Move RPC dispatch table registration to wallet/ code (Jonas Schnelli) | |||
2016-01-20 | [RPC, Wallet] Move RPC dispatch table registration to wallet/ code | Jonas Schnelli | |
Allow extending the rpc dispatch table by appending commands when server is not running. | |||
2016-01-20 | Merge #7222: RPC: Indicate which transactions are signaling opt-in RBF | Wladimir J. van der Laan | |
eaa8d27 RPC: indicate which transactions are replaceable (Suhas Daftuar) | |||
2016-01-20 | Merge #7350: Banlist updates | Wladimir J. van der Laan | |
e8600c9 banlist (bugfix): allow CNode::SweepBanned() to run on interval (Philip Kaufmann) 2977c24 banlist: add more banlist infos to log / add GUI signal (Philip Kaufmann) ce479aa banlist: better handling of banlist in StartNode() (Philip Kaufmann) 57c77fe banlist: update set dirty to be more fine grained (Philip Kaufmann) | |||
2016-01-20 | [walletdb] Fix syntax error in key parser | MarcoFalke | |
2016-01-19 | RPC: indicate which transactions are replaceable | Suhas Daftuar | |
Add "bip125-replaceable" output field to listtransactions and gettransaction which indicates if an unconfirmed transaction, or any unconfirmed parent, is signaling opt-in RBF according to BIP 125. | |||
2016-01-19 | Merge pull request #7281: Improve CheckInputs() comment about sig verification | Wladimir J. van der Laan | |
fd83615 Improve CheckInputs() comment about sig verification (Peter Todd) | |||
2016-01-19 | Merge pull request #7164: Do not download transactions during initial ↵ | Wladimir J. van der Laan | |
blockchain sync 39a525c Do not download transactions during inital sync (ptschip) | |||
2016-01-19 | Bugfix: Actually use _COPYRIGHT_HOLDERS_SUBSTITUTION everywhere | Luke Dashjr | |
2016-01-18 | Merge pull request #7194 | Wladimir J. van der Laan | |
135d6ec Add RPC tests for getblockheader. (James O'Beirne) 4745636 Add RPC documentation for getblockheader[chainwork]. (James O'Beirne) 16d4fce Add assert_is_hex_string and assert_is_hash_string to RPC test utils. (James O'Beirne) | |||
2016-01-18 | Merge pull request #7232 | Wladimir J. van der Laan | |
94bdd71 Added help text for chainwork value (Gregory Sanders) | |||
2016-01-18 | Merge pull request #7208 | Wladimir J. van der Laan | |
64360f1 Make max tip age an option instead of chainparam (Wladimir J. van der Laan) | |||
2016-01-18 | Merge pull request #7290 | Wladimir J. van der Laan | |
fa461df Clarify mocktime help message (MarcoFalke) faa572a [init] Help Msg: Use Params(CBaseChainParams::MAIN) (MarcoFalke) fa6ab96 [init] Add missing help for args (MarcoFalke) fac11ea [init] Fix error message of maxtxfee invalid amount (MarcoFalke) | |||
2016-01-18 | Merge pull request #7313 | Wladimir J. van der Laan | |
0331aa3 Fixing typos on security-check.py and torcontrol.cpp (calebogden) | |||
2016-01-18 | Merge pull request #7329 | Wladimir J. van der Laan | |
9d263bd Typo fixes in comments (Chris Wheeler) | |||
2016-01-18 | Merge pull request #7363 | Wladimir J. van der Laan | |
bd34174 Update license year range to 2016 (Prayag Verma) | |||
2016-01-17 | [qt] Windows: Make rpcconsole monospace font larger | MarcoFalke | |
2016-01-17 | Update license year range to 2016 | Prayag Verma | |
2016-01-17 | Typo fixes in comments | Chris Wheeler | |
2016-01-16 | Remove copyright header from autogenerated chainparamsseeds.h | MarcoFalke | |
2016-01-16 | Merge pull request #7322 | Wladimir J. van der Laan | |
c0cf48d c++11: add scoped enum fallbacks to CPPFLAGS rather than defining them locally (Cory Fields) | |||
2016-01-15 | Merge branch 'master' into 20150703_banlist_updates | Luke Dashjr | |
2016-01-15 | Build against system UniValue when available | Luke Dashjr | |