aboutsummaryrefslogtreecommitdiff
path: root/src/qt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/qt/Makefile.am')
-rw-r--r--src/qt/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/qt/Makefile.am b/src/qt/Makefile.am
index 863274e80c..abd8a9f118 100644
--- a/src/qt/Makefile.am
+++ b/src/qt/Makefile.am
@@ -220,10 +220,10 @@ bitcoinstrings.cpp: FORCE
translate: bitcoinstrings.cpp $(QT_FORMS_UI) $(QT_FORMS_UI) $(BITCOIN_QT_CPP) $(BITCOIN_QT_H) $(BITCOIN_MM)
@test -n $(LUPDATE) || echo "lupdate is required for updating translations"
- @$(LUPDATE) $^ -locations relative -no-obsolete -ts locale/bitcoin_en.ts
+ @QT_SELECT=$(QT_SELECT) $(LUPDATE) $^ -locations relative -no-obsolete -ts locale/bitcoin_en.ts
$(QT_QRC_CPP): $(QT_QRC) $(QT_QM) $(QT_FORMS_H) $(RES_ICONS) $(RES_IMAGES) $(RES_MOVIES) $(PROTOBUF_H)
- @cd $(abs_srcdir); test -f $(RCC) && $(RCC) -name bitcoin -o $(abs_builddir)/$@ $< || \
+ @cd $(abs_srcdir); test -f $(RCC) && QT_SELECT=$(QT_SELECT) $(RCC) -name bitcoin -o $(abs_builddir)/$@ $< || \
echo error: could not build $@
$(SED) -i.bak -e '/^\*\*.*Created:/d' $@ && rm $@.bak
$(SED) -i.bak -e '/^\*\*.*by:/d' $@ && rm $@.bak