aboutsummaryrefslogtreecommitdiff
path: root/src/qt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/qt/CMakeLists.txt')
-rw-r--r--src/qt/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/qt/CMakeLists.txt b/src/qt/CMakeLists.txt
index dc62d0f57e..7ec2b74cc8 100644
--- a/src/qt/CMakeLists.txt
+++ b/src/qt/CMakeLists.txt
@@ -13,9 +13,6 @@ endif()
get_target_property(qt_lib_type Qt5::Core TYPE)
-# TODO: After the transition from Autotools to CMake,
-# all `Q_IMPORT_PLUGIN` macros can be deleted from the
-# qt/bitcoin.cpp and qt/test/test_main.cpp source files.
function(import_plugins target)
if(qt_lib_type STREQUAL "STATIC_LIBRARY")
set(plugins Qt5::QMinimalIntegrationPlugin)
@@ -49,7 +46,7 @@ file(GLOB ts_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} locale/*.ts)
set_source_files_properties(${ts_files} PROPERTIES OUTPUT_LOCATION ${CMAKE_CURRENT_BINARY_DIR}/locale)
qt5_add_translation(qm_files ${ts_files})
-configure_file(bitcoin_locale.qrc bitcoin_locale.qrc COPYONLY)
+configure_file(bitcoin_locale.qrc bitcoin_locale.qrc USE_SOURCE_PERMISSIONS COPYONLY)
# The bitcoinqt sources have to include headers in
# order to parse them to collect translatable strings.
@@ -136,7 +133,6 @@ target_link_libraries(bitcoinqt
bitcoin_cli
leveldb
Boost::headers
- $<TARGET_NAME_IF_EXISTS:NATPMP::NATPMP>
$<TARGET_NAME_IF_EXISTS:MiniUPnPc::MiniUPnPc>
$<TARGET_NAME_IF_EXISTS:PkgConfig::libqrencode>
$<$<PLATFORM_ID:Darwin>:-framework\ AppKit>