aboutsummaryrefslogtreecommitdiff
path: root/src/ipc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/ipc/CMakeLists.txt')
-rw-r--r--src/ipc/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/ipc/CMakeLists.txt b/src/ipc/CMakeLists.txt
new file mode 100644
index 0000000000..904d72f56e
--- /dev/null
+++ b/src/ipc/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Copyright (c) 2023-present The Bitcoin Core developers
+# Distributed under the MIT software license, see the accompanying
+# file COPYING or https://opensource.org/license/mit/.
+
+add_library(bitcoin_ipc STATIC EXCLUDE_FROM_ALL
+ capnp/mining.cpp
+ capnp/protocol.cpp
+ interfaces.cpp
+ process.cpp
+)
+
+target_capnp_sources(bitcoin_ipc ${PROJECT_SOURCE_DIR}
+ capnp/common.capnp
+ capnp/echo.capnp
+ capnp/init.capnp
+ capnp/mining.capnp
+)
+
+target_link_libraries(bitcoin_ipc
+ PRIVATE
+ core_interface
+ univalue
+)