aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5135971eed..d25b27dd3e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -230,6 +230,7 @@ BITCOIN_CORE_H = \
node/mini_miner.h \
node/minisketchwrapper.h \
node/peerman_args.h \
+ node/protocol_version.h \
node/psbt.h \
node/transaction.h \
node/txreconciliation.h \
@@ -327,6 +328,7 @@ BITCOIN_CORE_H = \
util/time.h \
util/tokenpipe.h \
util/trace.h \
+ util/transaction_identifier.h \
util/translation.h \
util/types.h \
util/ui_change_type.h \
@@ -402,6 +404,7 @@ libbitcoin_node_a_SOURCES = \
kernel/coinstats.cpp \
kernel/context.cpp \
kernel/cs_main.cpp \
+ kernel/disconnected_transactions.cpp \
kernel/mempool_persist.cpp \
kernel/mempool_removal_reason.cpp \
mapport.cpp \
@@ -655,8 +658,7 @@ libbitcoin_consensus_a_SOURCES = \
uint256.cpp \
uint256.h \
util/strencodings.cpp \
- util/strencodings.h \
- version.h
+ util/strencodings.h
#
# common #
@@ -941,6 +943,7 @@ libbitcoinkernel_la_SOURCES = \
kernel/coinstats.cpp \
kernel/context.cpp \
kernel/cs_main.cpp \
+ kernel/disconnected_transactions.cpp \
kernel/mempool_persist.cpp \
kernel/mempool_removal_reason.cpp \
key.cpp \
@@ -949,7 +952,6 @@ libbitcoinkernel_la_SOURCES = \
node/chainstate.cpp \
node/utxo_snapshot.cpp \
policy/feerate.cpp \
- policy/fees.cpp \
policy/packages.cpp \
policy/policy.cpp \
policy/rbf.cpp \