aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 72f548c192..4199f7e89d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -174,6 +174,8 @@ BITCOIN_CORE_H = \
netbase.h \
netmessagemaker.h \
node/blockstorage.h \
+ node/caches.h \
+ node/chainstate.h \
node/coin.h \
node/coinstats.h \
node/context.h \
@@ -200,12 +202,12 @@ BITCOIN_CORE_H = \
rpc/blockchain.h \
rpc/client.h \
rpc/mining.h \
- rpc/net.h \
rpc/protocol.h \
rpc/rawtransaction_util.h \
rpc/register.h \
rpc/request.h \
rpc/server.h \
+ rpc/server_util.h \
rpc/util.h \
scheduler.h \
script/descriptor.h \
@@ -282,8 +284,8 @@ BITCOIN_CORE_H = \
wallet/ismine.h \
wallet/load.h \
wallet/receive.h \
- wallet/rpcwallet.h \
wallet/rpc/util.h \
+ wallet/rpc/wallet.h \
wallet/salvage.h \
wallet/scriptpubkeyman.h \
wallet/spend.h \
@@ -339,6 +341,8 @@ libbitcoin_server_a_SOURCES = \
net.cpp \
net_processing.cpp \
node/blockstorage.cpp \
+ node/caches.cpp \
+ node/chainstate.cpp \
node/coin.cpp \
node/coinstats.cpp \
node/context.cpp \
@@ -361,6 +365,7 @@ libbitcoin_server_a_SOURCES = \
rpc/net.cpp \
rpc/rawtransaction.cpp \
rpc/server.cpp \
+ rpc/server_util.cpp \
script/sigcache.cpp \
shutdown.cpp \
signet.cpp \
@@ -410,11 +415,15 @@ libbitcoin_wallet_a_SOURCES = \
wallet/interfaces.cpp \
wallet/load.cpp \
wallet/receive.cpp \
+ wallet/rpc/addresses.cpp \
wallet/rpc/backup.cpp \
+ wallet/rpc/coins.cpp \
wallet/rpc/encrypt.cpp \
+ wallet/rpc/spend.cpp \
wallet/rpc/signmessage.cpp \
+ wallet/rpc/transactions.cpp \
wallet/rpc/util.cpp \
- wallet/rpcwallet.cpp \
+ wallet/rpc/wallet.cpp \
wallet/scriptpubkeyman.cpp \
wallet/spend.cpp \
wallet/transaction.cpp \