aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index da65efa713..4cefc541d0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -72,7 +72,6 @@ endif
BITCOIN_CORE_H = \
addrman.h \
alert.h \
- allocators.h \
amount.h \
arith_uint256.h \
base58.h \
@@ -123,7 +122,10 @@ BITCOIN_CORE_H = \
script/standard.h \
serialize.h \
streams.h \
+ support/allocators/secure.h \
+ support/allocators/zeroafterfree.h \
support/cleanse.h \
+ support/pagelocker.h \
sync.h \
threadsafety.h \
timedata.h \
@@ -233,7 +235,6 @@ univalue_libbitcoin_univalue_a_SOURCES = \
# common: shared between bitcoind, and bitcoin-qt and non-server tools
libbitcoin_common_a_CPPFLAGS = $(BITCOIN_INCLUDES)
libbitcoin_common_a_SOURCES = \
- allocators.cpp \
arith_uint256.cpp \
amount.cpp \
base58.cpp \
@@ -264,6 +265,7 @@ libbitcoin_common_a_SOURCES = \
# backward-compatibility objects and their sanity checks are linked.
libbitcoin_util_a_CPPFLAGS = $(BITCOIN_INCLUDES)
libbitcoin_util_a_SOURCES = \
+ support/pagelocker.cpp \
chainparamsbase.cpp \
clientversion.cpp \
compat/glibc_sanity.cpp \