aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am30
1 files changed, 16 insertions, 14 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index da65efa713..2c607c632e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -72,7 +72,6 @@ endif
BITCOIN_CORE_H = \
addrman.h \
alert.h \
- allocators.h \
amount.h \
arith_uint256.h \
base58.h \
@@ -89,8 +88,7 @@ BITCOIN_CORE_H = \
compat.h \
compressor.h \
core_io.h \
- crypter.h \
- db.h \
+ wallet/db.h \
eccryptoverify.h \
ecwrapper.h \
hash.h \
@@ -123,7 +121,10 @@ BITCOIN_CORE_H = \
script/standard.h \
serialize.h \
streams.h \
+ support/allocators/secure.h \
+ support/allocators/zeroafterfree.h \
support/cleanse.h \
+ support/pagelocker.h \
sync.h \
threadsafety.h \
timedata.h \
@@ -138,9 +139,10 @@ BITCOIN_CORE_H = \
utilstrencodings.h \
utiltime.h \
version.h \
- walletdb.h \
- wallet.h \
- wallet_ismine.h \
+ wallet/crypter.h \
+ wallet/walletdb.h \
+ wallet/wallet.h \
+ wallet/wallet_ismine.h \
compat/byteswap.h \
compat/endian.h \
compat/sanity.h
@@ -196,13 +198,13 @@ libbitcoin_server_a_SOURCES = \
# when wallet enabled
libbitcoin_wallet_a_CPPFLAGS = $(BITCOIN_INCLUDES)
libbitcoin_wallet_a_SOURCES = \
- db.cpp \
- crypter.cpp \
- rpcdump.cpp \
- rpcwallet.cpp \
- wallet.cpp \
- wallet_ismine.cpp \
- walletdb.cpp \
+ wallet/crypter.cpp \
+ wallet/db.cpp \
+ wallet/rpcdump.cpp \
+ wallet/rpcwallet.cpp \
+ wallet/wallet.cpp \
+ wallet/wallet_ismine.cpp \
+ wallet/walletdb.cpp \
$(BITCOIN_CORE_H)
# crypto primitives library
@@ -233,7 +235,6 @@ univalue_libbitcoin_univalue_a_SOURCES = \
# common: shared between bitcoind, and bitcoin-qt and non-server tools
libbitcoin_common_a_CPPFLAGS = $(BITCOIN_INCLUDES)
libbitcoin_common_a_SOURCES = \
- allocators.cpp \
arith_uint256.cpp \
amount.cpp \
base58.cpp \
@@ -264,6 +265,7 @@ libbitcoin_common_a_SOURCES = \
# backward-compatibility objects and their sanity checks are linked.
libbitcoin_util_a_CPPFLAGS = $(BITCOIN_INCLUDES)
libbitcoin_util_a_SOURCES = \
+ support/pagelocker.cpp \
chainparamsbase.cpp \
clientversion.cpp \
compat/glibc_sanity.cpp \