aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/qt.mk
diff options
context:
space:
mode:
Diffstat (limited to 'depends/packages/qt.mk')
-rw-r--r--depends/packages/qt.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/depends/packages/qt.mk b/depends/packages/qt.mk
index df0cf5893f..9630df302f 100644
--- a/depends/packages/qt.mk
+++ b/depends/packages/qt.mk
@@ -128,6 +128,9 @@ $(package)_config_opts_darwin += -device-option MAC_TARGET=$(host)
$(package)_config_opts_darwin += -device-option XCODE_VERSION=$(XCODE_VERSION)
endif
+# for macOS on Apple Silicon (ARM) see https://bugreports.qt.io/browse/QTBUG-85279
+$(package)_config_opts_arm_darwin += -device-option QMAKE_APPLE_DEVICE_ARCHS=arm64
+
$(package)_config_opts_linux = -qt-xkbcommon-x11
$(package)_config_opts_linux += -qt-xcb
$(package)_config_opts_linux += -no-xcb-xlib