aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/libxcb.mk
diff options
context:
space:
mode:
Diffstat (limited to 'depends/packages/libxcb.mk')
-rw-r--r--depends/packages/libxcb.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/depends/packages/libxcb.mk b/depends/packages/libxcb.mk
index f29b577f8a..28f2bd6f25 100644
--- a/depends/packages/libxcb.mk
+++ b/depends/packages/libxcb.mk
@@ -13,8 +13,13 @@ define $(package)_preprocess_cmds
sed "s/pthread-stubs//" -i configure
endef
+# Don't install xcb headers to the default path in order to work around a qt
+# build issue: https://bugreports.qt.io/browse/QTBUG-34748
+# When using qt's internal libxcb, it may end up finding the real headers in
+# depends staging. Use a non-default path to avoid that.
+
define $(package)_config_cmds
- $($(package)_autoconf)
+ $($(package)_autoconf) --includedir=$(host_prefix)/include/xcb-shared
endef
define $(package)_build_cmds