aboutsummaryrefslogtreecommitdiff
path: root/contrib/guix
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/guix')
-rw-r--r--contrib/guix/libexec/prelude.bash2
-rw-r--r--contrib/guix/manifest.scm82
2 files changed, 6 insertions, 78 deletions
diff --git a/contrib/guix/libexec/prelude.bash b/contrib/guix/libexec/prelude.bash
index 4d5b06a54d..28ca23098d 100644
--- a/contrib/guix/libexec/prelude.bash
+++ b/contrib/guix/libexec/prelude.bash
@@ -51,7 +51,7 @@ fi
time-machine() {
# shellcheck disable=SC2086
guix time-machine --url=https://git.savannah.gnu.org/git/guix.git \
- --commit=160f78a4d92205df986ed9efcce7d3aac188cb24 \
+ --commit=77386bdbfe6b0c649c05ab37f08051d1ab3e5074 \
--cores="$JOBS" \
--keep-failed \
--fallback \
diff --git a/contrib/guix/manifest.scm b/contrib/guix/manifest.scm
index 12f57fcc45..7a030e5eab 100644
--- a/contrib/guix/manifest.scm
+++ b/contrib/guix/manifest.scm
@@ -11,7 +11,7 @@
(gnu packages gawk)
(gnu packages gcc)
((gnu packages installers) #:select (nsis-x86_64))
- ((gnu packages linux) #:select (linux-libre-headers-5.15 util-linux))
+ ((gnu packages linux) #:select (linux-libre-headers-6.1 util-linux))
(gnu packages llvm)
(gnu packages mingw)
(gnu packages moreutils)
@@ -92,7 +92,7 @@ chain for " target " development."))
(license (package-license xgcc)))))
(define base-gcc gcc-10)
-(define base-linux-kernel-headers linux-libre-headers-5.15)
+(define base-linux-kernel-headers linux-libre-headers-6.1)
(define* (make-bitcoin-cross-toolchain target
#:key
@@ -372,79 +372,8 @@ certificates or paths. Supports various options, including: validation at a
specific moment in time, whitelisting and revocation checks.")
(license license:expat))))
-(define-public python-altgraph
- (package
- (name "python-altgraph")
- (version "0.17")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ronaldoussoren/altgraph")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "09sm4srvvkw458pn48ga9q7ykr4xlz7q8gh1h9w7nxpf001qgpwb"))))
- (build-system python-build-system)
- (home-page "https://github.com/ronaldoussoren/altgraph")
- (synopsis "Python graph (network) package")
- (description "altgraph is a fork of graphlib: a graph (network) package for
-constructing graphs, BFS and DFS traversals, topological sort, shortest paths,
-etc. with graphviz output.")
- (license license:expat)))
-
-
-(define-public python-macholib
- (package
- (name "python-macholib")
- (version "1.14")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ronaldoussoren/macholib")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0aislnnfsza9wl4f0vp45ivzlc0pzhp9d4r08700slrypn5flg42"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-altgraph" ,python-altgraph)))
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-broken-tests
- (lambda _
- ;; This test is broken as there is no keyboard interrupt.
- (substitute* "macholib_tests/test_command_line.py"
- (("^(.*)class TestCmdLine" line indent)
- (string-append indent
- "@unittest.skip(\"Disabled by Guix\")\n"
- line)))
- (substitute* "macholib_tests/test_dyld.py"
- (("^(.*)def test_\\S+_find" line indent)
- (string-append indent
- "@unittest.skip(\"Disabled by Guix\")\n"
- line))
- (("^(.*)def testBasic" line indent)
- (string-append indent
- "@unittest.skip(\"Disabled by Guix\")\n"
- line))
- )
- #t)))))
- (home-page "https://github.com/ronaldoussoren/macholib")
- (synopsis "Python library for analyzing and editing Mach-O headers")
- (description "macholib is a Macho-O header analyzer and editor. It's
-typically used as a dependency analysis tool, and also to rewrite dylib
-references in Mach-O headers to be @executable_path relative. Though this tool
-targets a platform specific file format, it is pure python code that is platform
-and endian independent.")
- (license license:expat)))
-
(define-public python-signapple
- (let ((commit "7a96b4171a360abf0f0f56e499f8f9ed2116280d"))
+ (let ((commit "62155712e7417aba07565c9780a80e452823ae6a"))
(package
(name "python-signapple")
(version (git-version "0.1" "1" commit))
@@ -457,14 +386,13 @@ and endian independent.")
(file-name (git-file-name name commit))
(sha256
(base32
- "0aa4k180jnpal15yhncnm3g3z9gzmi7qb25q5l0kaj444a1p2pm4"))))
+ "1nm6rm4h4m7kbq729si4cm8rzild62mk4ni8xr5zja7l33fhv3gb"))))
(build-system python-build-system)
(propagated-inputs
`(("python-asn1crypto" ,python-asn1crypto)
("python-oscrypto" ,python-oscrypto)
("python-certvalidator" ,python-certvalidator)
- ("python-elfesteem" ,python-elfesteem)
- ("python-macholib" ,python-macholib)))
+ ("python-elfesteem" ,python-elfesteem)))
;; There are no tests, but attempting to run python setup.py test leads to
;; problems, just disable the test
(arguments '(#:tests? #f))