aboutsummaryrefslogtreecommitdiff
path: root/contrib/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/debian/rules')
-rwxr-xr-xcontrib/debian/rules28
1 files changed, 27 insertions, 1 deletions
diff --git a/contrib/debian/rules b/contrib/debian/rules
index 6885e38521..fcd0c39413 100755
--- a/contrib/debian/rules
+++ b/contrib/debian/rules
@@ -6,13 +6,20 @@
# $(if $(filter nocheck,$(DEB_BUILD_OPTIONS)),,src/test_bitcoin)
%:
- dh --with bash-completion $@
+ dh --with bash-completion --with systemd $@
override_dh_auto_clean:
if [ -f Makefile ]; then $(MAKE) distclean; fi
rm -rf Makefile.in aclocal.m4 configure src/Makefile.in src/bitcoin-config.h.in src/build-aux src/qt/Makefile.in src/qt/test/Makefile.in src/test/Makefile.in
QT=$(shell dpkg-vendor --derives-from Ubuntu && echo qt4 || echo qt5)
+# qt4 is very broken on arm
+ifeq ($(findstring arm,$(shell uname -m)),arm)
+ QT=qt5
+endif
+ifeq ($(findstring aarch64,$(shell uname -m)),aarch64)
+ QT=qt5
+endif
# Yea, autogen should be run on the source archive, but I like doing git archive
override_dh_auto_configure:
@@ -20,4 +27,23 @@ override_dh_auto_configure:
./configure --with-gui=$(QT)
override_dh_auto_test:
+ifeq ($(QT), qt4)
+ xvfb-run -n 99 -l make check
+else
make check
+endif
+
+# No SysV or Upstart init scripts included
+override_dh_installinit:
+ dh_installinit \
+ --noscripts
+
+# Don’t enable service by default
+override_dh_systemd_enable:
+ dh_systemd_enable \
+ --no-enable
+
+# Restart after upgrade
+override_dh_systemd_start:
+ dh_systemd_start \
+ --restart-after-upgrade