aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 343355ef65..58235d67c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,18 +96,8 @@ case $host in
;;
esac
-AC_ARG_ENABLE([c++20],
- [AS_HELP_STRING([--enable-c++20],
- [enable compilation in c++20 mode (disabled by default)])],
- [use_cxx20=$enableval],
- [use_cxx20=no])
-
-dnl Require C++17 compiler (no GNU extensions)
-if test "$use_cxx20" = "no"; then
-AX_CXX_COMPILE_STDCXX([17], [noext], [mandatory])
-else
+dnl Require C++20 compiler (no GNU extensions)
AX_CXX_COMPILE_STDCXX([20], [noext], [mandatory])
-fi
dnl Unless the user specified OBJCXX, force it to be the same as CXX. This ensures
dnl that we get the same -std flags for both.