aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3ed4549a88..6f7d8d19a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,6 +137,23 @@ AC_PATH_PROG(XGETTEXT,xgettext)
AC_PATH_PROG(HEXDUMP,hexdump)
PKG_PROG_PKG_CONFIG
+# Enable debug
+AC_ARG_ENABLE([debug],
+ [AS_HELP_STRING([--enable-debug],
+ [use debug compiler flags and macros (default is no)])],
+ [enable_debug=$enableval],
+ [enable_debug=no])
+
+if test "x$enable_debug" = xyes; then
+ if test "x$GCC" = xyes; then
+ CFLAGS="-g3 -O0 -DDEBUG"
+ fi
+
+ if test "x$GXX" = xyes; then
+ CXXFLAGS="-g3 -O0 -DDEBUG"
+ fi
+fi
+
## TODO: Remove these hard-coded paths and flags. They are here for the sake of
## compatibility with the legacy buildsystem.
##