aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index dde2d2eb98..f8d52e616a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -128,6 +128,7 @@ dnl Checks for programs.
AC_PROG_CXX
AC_PROG_CC
AC_PROG_CPP
+AC_PROG_CXXCPP
AC_PROG_INSTALL
AC_PROG_OBJC
m4_ifdef([AC_PROG_OBJCXX],[AC_PROG_OBJCXX])
@@ -334,8 +335,7 @@ AC_TRY_COMPILE([#include <sys/socket.h>],
)
dnl Check for libdb_cxx
-AC_CHECK_HEADER([db_cxx.h],,AC_MSG_ERROR(libdb_cxx headers missing))
-AC_CHECK_LIB([db_cxx], [main],, AC_MSG_ERROR(libdb_cxx missing))
+BITCOIN_FIND_BDB48
dnl Check for libminiupnpc (optional)
if test x$use_upnp != xno; then