aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 20 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index 18215a900d..c28c4d11e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,8 +69,8 @@ PKG_PROG_PKG_CONFIG
# Enable wallet
AC_ARG_ENABLE([wallet],
- [AS_HELP_STRING([--enable-wallet],
- [enable wallet (default is yes)])],
+ [AS_HELP_STRING([--disable-wallet],
+ [disable wallet (enabled by default)])],
[enable_wallet=$enableval],
[enable_wallet=yes])
@@ -87,7 +87,7 @@ AC_ARG_ENABLE([upnp-default],
[use_upnp_default=no])
AC_ARG_ENABLE(tests,
- AS_HELP_STRING([--enable-tests],[compile tests (default is yes)]),
+ AS_HELP_STRING([--disable-tests],[do not compile tests (default is to compile)]),
[use_tests=$enableval],
[use_tests=yes])
@@ -108,8 +108,8 @@ AC_ARG_WITH([qrencode],
[use_qr=auto])
AC_ARG_ENABLE([hardening],
- [AS_HELP_STRING([--enable-hardening],
- [attempt to harden the resulting executables (default is yes)])],
+ [AS_HELP_STRING([--disable-hardening],
+ [do not attempt to harden the resulting executables (default is to harden)])],
[use_hardening=$enableval],
[use_hardening=yes])
@@ -120,8 +120,8 @@ AC_ARG_ENABLE([reduce-exports],
[use_reduce_exports=no])
AC_ARG_ENABLE([ccache],
- [AS_HELP_STRING([--enable-ccache],
- [use ccache for building (default is yes if ccache is found)])],
+ [AS_HELP_STRING([--disable-ccache],
+ [do not use ccache for building (default is to use if found)])],
[use_ccache=$enableval],
[use_ccache=auto])
@@ -167,7 +167,7 @@ fi
## compatibility with the legacy buildsystem.
##
if test "x$CXXFLAGS_overridden" = "xno"; then
- CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter"
+ CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -Wno-self-assign"
fi
CPPFLAGS="$CPPFLAGS -DHAVE_BUILD_INFO -D__STDC_FORMAT_MACROS"
@@ -724,27 +724,12 @@ else
fi
fi
-CFLAGS_TEMP="$CFLAGS"
+CXXFLAGS_TEMP="$CXXFLAGS"
LIBS_TEMP="$LIBS"
-CFLAGS="$CFLAGS $SSL_CFLAGS $CRYPTO_CFLAGS"
+CXXFLAGS="$CXXFLAGS $SSL_CFLAGS $CRYPTO_CFLAGS"
LIBS="$LIBS $SSL_LIBS $CRYPTO_LIBS"
AC_CHECK_HEADER([openssl/ec.h],, AC_MSG_ERROR(OpenSSL ec header missing),)
-
-AC_MSG_CHECKING(for a supported OpenSSL version)
-AC_LINK_IFELSE([AC_LANG_PROGRAM([[
- #include <openssl/rand.h>
- ]],
- [[RAND_egd(NULL);]])],
- [AC_MSG_RESULT(yes)],
- [
- AC_ARG_WITH([libressl],
- [AS_HELP_STRING([--with-libressl],[Build with system LibreSSL (default is no; DANGEROUS; NOT SUPPORTED)])],
- [AC_MSG_WARN([Detected LibreSSL: This is NOT supported, and may break consensus compatibility!])],
- [AC_MSG_ERROR([Detected LibreSSL: This is NOT supported, and may break consensus compatibility!])]
- )]
-)
-
-CFLAGS="$CFLAGS_TEMP"
+CXXFLAGS="$CXXFLAGS_TEMP"
LIBS="$LIBS_TEMP"
BITCOIN_QT_PATH_PROGS([PROTOC], [protoc],$protoc_bin_path)
@@ -924,7 +909,7 @@ AC_SUBST(MINIUPNPC_CPPFLAGS)
AC_SUBST(MINIUPNPC_LIBS)
AC_CONFIG_FILES([Makefile src/Makefile share/setup.nsi share/qt/Info.plist src/test/buildenv.py])
AC_CONFIG_FILES([qa/pull-tester/run-bitcoind-for-test.sh],[chmod +x qa/pull-tester/run-bitcoind-for-test.sh])
-AC_CONFIG_FILES([qa/pull-tester/tests-config.sh],[chmod +x qa/pull-tester/tests-config.sh])
+AC_CONFIG_FILES([qa/pull-tester/tests_config.py],[chmod +x qa/pull-tester/tests_config.py])
dnl boost's m4 checks do something really nasty: they export these vars. As a
dnl result, they leak into secp256k1's configure and crazy things happen.
@@ -964,3 +949,11 @@ case $host in
chmod 755 libtool
;;
esac
+
+dnl Replace the BUILDDIR path with the correct Windows path if compiling on Native Windows
+case ${OS} in
+ *Windows*)
+ sed 's/BUILDDIR="\/\([[a-z]]\)/BUILDDIR="\1:/' qa/pull-tester/tests_config.py > qa/pull-tester/tests_config-2.py
+ mv qa/pull-tester/tests_config-2.py qa/pull-tester/tests_config.py
+ ;;
+esac