aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8a54c2f76e..7f90b5f395 100644
--- a/configure.ac
+++ b/configure.ac
@@ -147,12 +147,13 @@ AC_ARG_ENABLE([debug],
[enable_debug=no])
if test "x$enable_debug" = xyes; then
+ CPPFLAGS="$CPPFLAGS -DDEBUG -DDEBUG_LOCKORDER"
if test "x$GCC" = xyes; then
- CFLAGS="-g3 -O0 -DDEBUG"
+ CFLAGS="$CFLAGS -g3 -O0"
fi
if test "x$GXX" = xyes; then
- CXXFLAGS="-g3 -O0 -DDEBUG"
+ CXXFLAGS="$CXXFLAGS -g3 -O0"
fi
fi