aboutsummaryrefslogtreecommitdiff
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
authorGavin Andresen <gavinandresen@gmail.com>2013-12-09 19:36:39 -0800
committerGavin Andresen <gavinandresen@gmail.com>2013-12-09 19:36:39 -0800
commitd47bbbd2619910f197967e8a8e54ac5ccdfae338 (patch)
treed2337ab5a7ac78bc34ad03d8fc03234ebeff697d /src/test/Makefile.am
parent955787f83f49dab298763a3a119766494dede30f (diff)
parentfbc7a96d03200e55021c9e04f7fa9114272e6960 (diff)
downloadbitcoin-d47bbbd2619910f197967e8a8e54ac5ccdfae338.tar.xz
Merge pull request #3368 from laanwj/2013_11_disable_wallet_mining
Allow mining RPCs with --disable-wallet
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index dccd264e5a..ccc8da1690 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -31,14 +31,14 @@ test_bitcoin_SOURCES = alert_tests.cpp \
allocator_tests.cpp base32_tests.cpp base58_tests.cpp base64_tests.cpp \
bignum_tests.cpp bloom_tests.cpp canonical_tests.cpp checkblock_tests.cpp \
Checkpoints_tests.cpp compress_tests.cpp DoS_tests.cpp getarg_tests.cpp \
- key_tests.cpp mruset_tests.cpp multisig_tests.cpp \
+ key_tests.cpp miner_tests.cpp mruset_tests.cpp multisig_tests.cpp \
netbase_tests.cpp pmt_tests.cpp rpc_tests.cpp script_P2SH_tests.cpp \
script_tests.cpp serialize_tests.cpp sigopcount_tests.cpp test_bitcoin.cpp \
transaction_tests.cpp uint160_tests.cpp uint256_tests.cpp util_tests.cpp \
sighash_tests.cpp $(JSON_TEST_FILES) $(RAW_TEST_FILES)
if ENABLE_WALLET
-test_bitcoin_SOURCES += accounting_tests.cpp wallet_tests.cpp miner_tests.cpp rpc_wallet_tests.cpp
+test_bitcoin_SOURCES += accounting_tests.cpp wallet_tests.cpp rpc_wallet_tests.cpp
endif
nodist_test_bitcoin_SOURCES = $(BUILT_SOURCES)