aboutsummaryrefslogtreecommitdiff
path: root/src/qt/test/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-01-11 12:51:03 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2014-01-11 12:51:12 +0100
commit061aff4c46babdc30bb9f52f874a24edd8d14d82 (patch)
tree6a0820ae13a8131ce3a0e2e0acf3754089b88ba3 /src/qt/test/Makefile.am
parent054be736d4773804b51ed67d6b7fe0e1b15d1d1b (diff)
parentb7f4b6d35da7b63529a728eb9333fe424b2a5c6d (diff)
downloadbitcoin-061aff4c46babdc30bb9f52f874a24edd8d14d82.tar.xz
Merge pull request #3392
b7f4b6d GUI for --disable-wallet compiles and -disablewallet mode (Wladimir J. van der Laan) ec41342 build: pass correct defs and include path to moc (Wladimir J. van der Laan)
Diffstat (limited to 'src/qt/test/Makefile.am')
-rw-r--r--src/qt/test/Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/src/qt/test/Makefile.am b/src/qt/test/Makefile.am
index 0150524337..da54ef376b 100644
--- a/src/qt/test/Makefile.am
+++ b/src/qt/test/Makefile.am
@@ -8,16 +8,27 @@ AM_CPPFLAGS += -I$(top_srcdir)/src \
bin_PROGRAMS = test_bitcoin-qt
TESTS = test_bitcoin-qt
-TEST_QT_MOC_CPP = moc_uritests.cpp moc_paymentservertests.cpp
+TEST_QT_MOC_CPP = moc_uritests.cpp
+
+if ENABLE_WALLET
+TEST_QT_MOC_CPP += moc_paymentservertests.cpp
+endif
TEST_QT_H = uritests.h paymentservertests.h paymentrequestdata.h
BUILT_SOURCES = $(TEST_QT_MOC_CPP)
test_bitcoin_qt_CPPFLAGS = $(AM_CPPFLAGS) $(QT_INCLUDES) $(QT_TEST_INCLUDES)
-test_bitcoin_qt_SOURCES = test_main.cpp uritests.cpp paymentservertests.cpp $(TEST_QT_H)
+test_bitcoin_qt_SOURCES = test_main.cpp uritests.cpp $(TEST_QT_H)
+if ENABLE_WALLET
+test_bitcoin_qt_SOURCES += paymentservertests.cpp
+endif
nodist_test_bitcoin_qt_SOURCES = $(TEST_QT_MOC_CPP)
-test_bitcoin_qt_LDADD = $(LIBBITCOINQT) $(LIBBITCOIN_SERVER) $(LIBBITCOIN_WALLET) $(LIBBITCOIN_CLI) $(LIBBITCOIN_COMMON) $(LIBLEVELDB) \
+test_bitcoin_qt_LDADD = $(LIBBITCOINQT) $(LIBBITCOIN_SERVER)
+if ENABLE_WALLET
+test_bitcoin_qt_LDADD += $(LIBBITCOIN_WALLET)
+endif
+test_bitcoin_qt_LDADD += $(LIBBITCOIN_CLI) $(LIBBITCOIN_COMMON) $(LIBLEVELDB) \
$(LIBMEMENV) $(BOOST_LIBS) $(QT_DBUS_LIBS) $(QT_TEST_LIBS) $(QT_LIBS) \
$(QR_LIBS) $(PROTOBUF_LIBS) $(BDB_LIBS)