aboutsummaryrefslogtreecommitdiff
path: root/src/qt/test/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-01-12 10:02:55 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2014-01-12 10:03:02 +0100
commit0e469b516770ebfb6596cf71532a8c9c233527ca (patch)
tree136d2afb6b38a7470a331ce9a68bf3aa716f06bc /src/qt/test/Makefile.am
parent0a4fefe18faed00db3a89122c0e0900f9c7ad816 (diff)
parentd464edfb8c4fe8415980614ceb95dff9bfadbf45 (diff)
Merge pull request #3513
d464edf [Qt] fix alphabetical ordering in Makefile.am (Philip Kaufmann)
Diffstat (limited to 'src/qt/test/Makefile.am')
-rw-r--r--src/qt/test/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/qt/test/Makefile.am b/src/qt/test/Makefile.am
index 9c3f0417ac..00ccfadf3f 100644
--- a/src/qt/test/Makefile.am
+++ b/src/qt/test/Makefile.am
@@ -16,12 +16,13 @@ endif
TEST_QT_H = \
uritests.h \
- paymentservertests.h \
- paymentrequestdata.h
+ paymentrequestdata.h \
+ paymentservertests.h
BUILT_SOURCES = $(TEST_QT_MOC_CPP)
test_bitcoin_qt_CPPFLAGS = $(AM_CPPFLAGS) $(QT_INCLUDES) $(QT_TEST_INCLUDES)
+
test_bitcoin_qt_SOURCES = \
test_main.cpp \
uritests.cpp \
@@ -30,7 +31,9 @@ if ENABLE_WALLET
test_bitcoin_qt_SOURCES += \
paymentservertests.cpp
endif
+
nodist_test_bitcoin_qt_SOURCES = $(TEST_QT_MOC_CPP)
+
test_bitcoin_qt_LDADD = $(LIBBITCOINQT) $(LIBBITCOIN_SERVER)
if ENABLE_WALLET
test_bitcoin_qt_LDADD += $(LIBBITCOIN_WALLET)
@@ -40,4 +43,3 @@ test_bitcoin_qt_LDADD += $(LIBBITCOIN_CLI) $(LIBBITCOIN_COMMON) $(LIBLEVELDB) \
$(QR_LIBS) $(PROTOBUF_LIBS) $(BDB_LIBS)
CLEANFILES = $(BUILT_SOURCES) *.gcda *.gcno
-