aboutsummaryrefslogtreecommitdiff
path: root/src/qt/Makefile.am
diff options
context:
space:
mode:
authorPhilip Kaufmann <phil.kaufmann@t-online.de>2014-04-10 08:19:58 +0200
committerPhilip Kaufmann <phil.kaufmann@t-online.de>2014-04-15 11:57:55 +0200
commitd282c1fb64ae570caab951247e6ead4b9059043d (patch)
tree4e447f31035eeef8268a8c333e45cd2dcd01d092 /src/qt/Makefile.am
parent74dd52a9fc13851a6ec847da985388a6bfb70be7 (diff)
downloadbitcoin-d282c1fb64ae570caab951247e6ead4b9059043d.tar.xz
[Qt] catch Windows shutdown events while client is running
- prevents unsafe shutdowns on Windows, which is known to be able to cause problems with wallet.dat - if a users ends a Windows session, this will initiate a client shutdown and show a Windows dialog, that tells the user what is going on (for Windows Vista and higher it will even show a reason for blocking the Windows session end)
Diffstat (limited to 'src/qt/Makefile.am')
-rw-r--r--src/qt/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/qt/Makefile.am b/src/qt/Makefile.am
index f875ac283b..44d2964501 100644
--- a/src/qt/Makefile.am
+++ b/src/qt/Makefile.am
@@ -211,7 +211,8 @@ BITCOIN_QT_H = \
walletframe.h \
walletmodel.h \
walletmodeltransaction.h \
- walletview.h
+ walletview.h \
+ winshutdownmonitor.h
RES_ICONS = \
res/icons/add.png \
@@ -277,7 +278,8 @@ BITCOIN_QT_CPP = \
rpcconsole.cpp \
splashscreen.cpp \
trafficgraphwidget.cpp \
- utilitydialog.cpp
+ utilitydialog.cpp \
+ winshutdownmonitor.cpp
if ENABLE_WALLET
BITCOIN_QT_CPP += \