aboutsummaryrefslogtreecommitdiff
path: root/src/qt/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2013-11-29 16:50:11 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2013-12-04 12:46:13 +0100
commit4f9e993bc9beb8261022aad6668d675dccb1e6c4 (patch)
treef6c5b75c65774abf96619076d9f58193b55c351c /src/qt/Makefile.am
parentd004d7279ff21b7ee90207a850ec26ba044799bb (diff)
downloadbitcoin-4f9e993bc9beb8261022aad6668d675dccb1e6c4.tar.xz
Add --disable-wallet option to build system
Make it possible to build Bitcoin without wallet (and thus without BDB) so that it only functions as node.
Diffstat (limited to 'src/qt/Makefile.am')
-rw-r--r--src/qt/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/qt/Makefile.am b/src/qt/Makefile.am
index e302adc89f..08846604ea 100644
--- a/src/qt/Makefile.am
+++ b/src/qt/Makefile.am
@@ -197,7 +197,7 @@ endif
bitcoin_qt_CPPFLAGS = $(AM_CPPFLAGS) $(QT_INCLUDES) \
-I$(top_srcdir)/src/qt/forms
bitcoin_qt_SOURCES = bitcoin.cpp
-bitcoin_qt_LDADD = libbitcoinqt.a $(LIBBITCOIN_SERVER) $(LIBBITCOIN_CLI) $(LIBBITCOIN_COMMON) $(LIBLEVELDB) $(LIBMEMENV) \
+bitcoin_qt_LDADD = libbitcoinqt.a $(LIBBITCOIN_SERVER) $(LIBBITCOIN_WALLET) $(LIBBITCOIN_CLI) $(LIBBITCOIN_COMMON) $(LIBLEVELDB) $(LIBMEMENV) \
$(BOOST_LIBS) $(QT_LIBS) $(QT_DBUS_LIBS) $(QR_LIBS) $(PROTOBUF_LIBS) $(BDB_LIBS)
# forms/foo.h -> forms/ui_foo.h