aboutsummaryrefslogtreecommitdiff
path: root/src/qt/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2013-09-14 11:52:42 -0400
committerCory Fields <cory-nospam-@coryfields.com>2013-09-14 12:11:38 -0400
commit21ffa3ce3ad6f8909d88edca1a1208a091078bb5 (patch)
tree544bd1c8ed8c79bc90e24571dd442c9dc7417771 /src/qt/Makefile.am
parentf3f09462cd5c9f9964a3c0631f5bdceab8768b0c (diff)
downloadbitcoin-21ffa3ce3ad6f8909d88edca1a1208a091078bb5.tar.xz
autotools: add translate target for qt translations
Diffstat (limited to 'src/qt/Makefile.am')
-rw-r--r--src/qt/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/qt/Makefile.am b/src/qt/Makefile.am
index af8ebee6c6..33c5825eb3 100644
--- a/src/qt/Makefile.am
+++ b/src/qt/Makefile.am
@@ -153,8 +153,16 @@ QT_FORMS_H=$(join $(dir $(QT_FORMS_UI)),$(addprefix ui_, $(notdir $(QT_FORMS_UI:
#locale/foo.ts -> locale/foo.qm
QT_QM=$(QT_TS:.ts=.qm)
+.PHONY: FORCE
.SECONDARY: $(QT_QM)
+bitcoinstrings.cpp: FORCE
+ $(MAKE) -C $(top_srcdir)/src qt/bitcoinstrings.cpp
+
+translate: bitcoinstrings.cpp $(QT_FORMS_UI) $(QT_FORMS_UI) $(BITCOIN_QT_CPP) $(BITCOIN_QT_H) $(BITCOIN_MM) $(QR_CPP)
+ @test -n $(LUPDATE) || echo "lupdate is required for updating translations"
+ @$(LUPDATE) $^ -locations relative -no-obsolete -ts locale/bitcoin_en.ts
+
$(QT_QRC_CPP): $(QT_QRC) $(QT_QM) $(QT_FORMS_H) $(RES_ICONS) $(RES_IMAGES) $(RES_MOVIES) $(PROTOBUF_H)
@cd $(abs_srcdir); test -f $(RCC) && $(RCC) -name bitcoin -o $(abs_builddir)/$@ $< || \
echo error: could not build $@